David W.'s picture

OK... this is driving me nuts...

Can someone please tell me where this is coming from so I can bang it out? I've dug through every single one of the files in /etc/apt/sources.list.d/  and there is no such entry anywhere that should be generating this error (of course it only started a month or so back due to EOL for the OS).

W: Failed to fetch http://httpredir.debian.org/debian/dists/jessie-backports/main/binary-am...  404  Not Found [IP: 80]


Jeremy Davis's picture

Another user actually highlighted this issue relatively recently, and I've been meaning to do a blog post on it. Unfortunately there are only so many hours in the day and I've been crazy busy. Regardless, it's far from ideal and I do apologise that I haven't been more proactive about it.

As you note, the cause of the issue is due to changes within Debian. Although it's also well worth noting that Jessie is not EOL. It's just moved to what is called LTS (Long Term Support). Actually it moved to LTS back in June last year. But they've only just removed the backports repo. AFAIK, the rationale behind that was that backports is not covered by LTS and because it still existed, there was some confusion around that.

Unfortunately, we didn't consider that factor when we decided to include backports as part of the default setup for v14.2. FWIW we enabled it to install Dehydrated, the Let's Encrypt client that we leverage for the Confconsole Let's Encrypt plugin that we developed.

So to resolve the issue, there should be a sources list file named 'backports.sources.list' (full path: /etc/apt/sources.list.d/backports.sources.list). Simply rename the file something like 'backports.sources.list.disabled'. I.e.:

mv /etc/apt/sources.list.d/backports.sources.list /etc/apt/sources.list.d/backports.sources.list.disabled

And you should be good to go.

PS, it's worth noting, that if you are not using the Let's Encrypt Confconsole module, then this should have no detrimental effect. If you are using the Let's Encrypt Confconsole module, then you're also likely to be fine for now at least. Although there is a risk that at some point in the future, if Let's Encrypt change things, the current client may cease to function. If that occurs, then you'd need to update Dehydrated. One way to do that would be to migrate to a newer version of TurnKey (v15.x installs Dehydrated from the standard repos, which wasn't an option on Jessie). Or do a Debian "in place" upgrade to a Debian 9/Stretch base. Alternatively, you could just update Dehydrated, either by installing it directly from upstream, or configure your server to install just that single package from Debian 9/Stretch. If you go that final path, then please be sure to adjust the pinning file: /etc/apt/preferences.d/dehydrated-backports.pref so that it will be installed (and nothing else).

Good luck with it.

David W.'s picture

Just tried that this morning... and saddly... no... did not 'fix' it.

I haven't got a clue what's calling that at this point...

Err http://http.debian.net jessie-backports/main amd64 Packages
  404  Not Found [IP: 80]


Jeremy Davis's picture

TBH, I'm super surprised that that didn't work. Anyway...

To search all possible sources.list entries for lines that contain 'jessie-backports', you can use grep, like this:

grep -r jessie-backports /etc/apt/sources.list*

That should return a list of results (or at least one) in the format:

/path/to/file:line in file that contains jessie-backports

Then to disable it, either disable the whole file (as per above) or just comment the line out. Do that by putting a hash/pound symbol right at the start of the line. I.e.

line of text


#line of text

Please post back on which file you find the offending entry in.

David W.'s picture

<BOOM!> Got it!

I had tried bang'n out ("#") all of the lines in both of the 'backport' files (there are two) but that hadn't worked. Grep showed both of the files, on already having been renamed so I just renamed the second and *POOF*... lots of updates to inall, not the least of which being the kernel.

Thank you! 


Jeremy Davis's picture

You're most welcome. Glad to hear it's sorted. :)

Add new comment