deutrino's picture

Hi there, I've tried to boot two ISO images (LAMP and TKLdev, both 16.0) in QEMU/KVM on Linux Mint 20 and both of them technicolor crash while booting the installer.

This is Linux Mint 20 running on kernel 5.4.0 on a Thinkpad T480, it's a late-model CPU.

Package qemu-kvm is version 1:4.2-3ubuntu6.7 (amd64).

This problem is 100% reproducible and makes TKL unusable w/KVM for me on this platform. Is this a known thing or does anyone have any hints as to what the problem may be? Is it possible to try a different image type?

Currently VMware Workstation Player 16.0.0 is not working for me on this platform (trouble building kernel modules) so I have not been able to verify whether the problem occurs there as well. But the exact same ISOs boot okay in VMware Player on a machine running Ubuntu.

Jeremy Davis's picture

It seems that there is some issue with our ISO on newer QEMU/KVM?!

A similar sounding issue has been reported on the tracker and has been confirmed. As I note there, I haven't been able to reproduce it myself, but I'm using older QEMU/KVM (v3.1) so I'm guessing that's a factor...

If you have anything further to add there, please do so.

As I think I noted in my response on the issue, there is a known issue with VMware products when installing from ISO (OVA is fine). Grub can't find the right volume automatically when installing to LVM - but I'm not sure if that is at all related to this QEMU/KVM issue.

FWIW it's been reported that both ISO and OVA work fine with latest VirtualBox. I personally tested with v6.0.x, but it's been reported as ok on v6.1.x too.

It might be worth trying the VMDK build with QEMU/KVM and see if that works for you? AFAIK QEMU/KVM can happily use a VMDK image; or it could be converted via `qemu-img' tool if you prefer. (Might even be worth trying both?).

I run Sid on one of my systems and I note that the repos have QEMU/KVM v5.1

so I'll see if that works ASAP and report back.

Add new comment