L. Arnold's picture


I am trying to load a "addon" to current Odoo build on TKL/Hub.

In the past I could add a new path in the Odoo Conf File

This is Odoo 14, but TKL Odoo has a significantly different structure.

Reads Now

addons_path = /usr/lib/python3/dist-packages/odoo/addons

What I would like:

addons_path = /usr/lib/python3/dist-packages/odoo/addons,/opt/odoo/14/addons

Note that I am adding a folder not in the dist packages but in the Opt Directory


The old system I have been running has the following info in it (I like the old documentation here)

# Specify the addons_path folders ordered by priority  
# addons_path=/first/path/,/second/path/
# addons_path = /opt/openerp/odoo/addons
addons_path = opt/openerp/odoo/addons,/opt/openerp/oca/connector

The Owner moved from openerp to odoo (I have assigned this to the Addon).

Unfortunately, when I add the extra folder the whole system crawls to a stop.  Icons change etc.
So, I just added a folder to the /dist-packages/odoo/addons folder and removed the comma(,) and the second addons path.

That brought the new Addon I need to Odoo.  

Now though I can't install it... I am being told that I need the "squareup" Python package.

In WebShell (12320_

If I type

"pip install squareup" it appears that PIP is not installed.

If I type "install pip"
I get an error that it cannot be done...

Seems I could download get-pip.py ...  but there are many versions of python.  Perhaps I need to type it from the version folder.  (tried that.. does not work)..  also tried tet-pip.py from the python3 folder.

Guidance will be appreciated.

Thank you,


L. Arnold's picture

I tried the following

curl https://bootstrap.pypa.io/get-pip.py -o get-pip.py
	python get-pip.py

but got the following error. Will try with 3.0

~# python get-pip.py
ERROR: This script does not work on Python 2.7 The minimum supported Python
  version is 3.6. Please use https://bootstrap.pypa.io/pip/2.7/get-pip.py
L. Arnold's picture

Though I got the error, I went through again and was able to get Pip installed as well as the dependency.

More work to do now getting the connection but not the issue for here.


Jeremy Davis's picture

IIRC Odoo 14 (in v16.1) uses Python3. The default pip executable for Python3 on Debian is 'pip3'. ('pip' will run the Python2 version of 'pip'). So to install 'squareup' with pip for python3, would look like this:

pip3 install squareup

If for some reason it doesn't already include pip (pip3), then install it like this:

apt update
apt install python3-pip -y

Re the addons path, as I'm not completely familiar with Odoo, I'm not 100%, but a comma separated list seems reasonable. AFAIK they should always be full, explicit paths. In other words always start with a slash ('/'). They should always be directories, so the trailing slash may not be required (although it might too).

Re things grinding to a halt with the additional addons path. I'm not 100% sure, but my guess is that if there are a lot of addons included, then it probably loads them all into the running code (whether they are used or not). So if you add a directory that includes tons of addons in it, increased resource usage (resulting in slower functioning; probably especially slower startup) is probably expected.

L. Arnold's picture

I only had one add on in the "Extra Addons" path.  Still ground to a halt.
Putting it in the Debian (ie TKL Odoo) folder brought it right up.

Seemed perhaps there is some sort of dissability to move far from that folder.  I will test again.

L. Arnold's picture

I will try to Uninstall and reinstall the 3.0

I can see in tracebacks that everything is going along in 3.0 then it seems to go wrong at 3.7..

anyway view from here anyway.

L. Arnold's picture

I am not quite clear as to whether I can mix Python 3.0 with Python 3.7.  It appears that the package I am trying to install requires Python3 3.7  (or Python2 2.79 or later).

Seems I am a bit stuck between systems if Odoo is running Python3.0.

Perhaps I could upgrade the Python for Odoo.

Jeremy Davis's picture

v16.x is based on Debian 10/Buster; which has Python 3.7. FYI when I refer to 'python3', that's the executable and is in contrast to python2 (aka 'python' - no number; aka v2.7).

So you should be good to go?!

FYI you can double check with:

python3 --version

You should get:

Python 3.7.3
L. Arnold's picture

It did load..  but ran with errors.  Perhaps a bad "addon".  the company who made it has not replied for a few days.

I did a work around with another setup so should be good for now.

I will test for "versions" as you outline.

Thank you,


Jeremy Davis's picture

No worries Landis. Hopefully they get back to you soon. If you need a hand further, please do post back. Good luck with it all.

Add new comment