Forum: 
Tags: 

No memory usage details or graph for my Cisco devices.

Don Maker's picture

I have various Cisco devices ( catalyst switches, ios routers, ios-xe, etc), but none of them are showing any memory usage details in observium. I was surprised by this as observium did a remarkable job of recognizing and displaying information for things that most snmp tools do not, Qnap for example. It does recognize my Cisco devices and reports back on just about everything, but memory. Other tools I tried, such as Manageengine, PRTG, etc reported the memory with no issue. So, I'm skeptical that there is anything wrong with my snmp setup.

 

I would really love to get memory usage for my Cisco devices. If anyone has any suggestions, I'm all ears. 

 

Thanks

 

Jeremy Davis's picture

Whilst we build the appliance, we certainly aren't the experts in the use of the software. So it may be worth consulting with them if you can't work it out.

However, in the process of trying to find you a link to their community support, I discovered something that may be worth trying first. If you can confirm that it resolves your issue, then IMO we should consider tweaking our default appliance.

Their docs note that Debian (as of Squeeze) does not automatically include SNMP MIBs. I'm no expert in the area, but a quick google suggests that this may be the cause of your missing info! On that doc page it appears that there are 2 options, either install from Debian "non-free" repo (free of cost, just not a "free" software license) or configure Observium to use MIBs that are included.

Looking through the appliance build code, I can see that we are using the Observium MIBs, but our config doesn't quite match theirs. Perhaps the additional info will be enough?

I.e. edit the line in /etc/snmp/snmp.conf that looks like this:

mibdirs /opt/observium/mibs
So instead it looks like this:
mibdirs /opt/observium/mibs:/opt/observium/mibs/net-snmp

I suspect that restarting SNMP is required for the new setting to take effect. Rebooting is always another option... If that still doesn't resolve it, perhaps it's worth trying to installing MIBs from Debian non-free?

Also it's probably worth checking that you are using the latest version of Observium (and if not update it). IIRC there has been at least one new release (perhaps 2?) since we last rebuilt the appliance (which we'll be doing it again soon). FWIW the docs on upgrading are here. A community member has also submitted a suggested update script.

Hope that helps.

Don Maker's picture

Thank you for the response. I have made the suggested change. I will wait a bit and see if memory graphs appear.

 

 

Thanks

 

Don Maker's picture

Hmm, no difference.

Don Maker's picture

I installed the CE Observium on an Ubuntu vm and it is working great. I am now getting my Cisco memory usage graphs and a bunch of other stuff that I didn't even know I was missing out on. 

 

 

Jeremy Davis's picture

If you've done a clean install of Observium on Ubuntu and it looks different, then my guess is that it's a newer version. We will be releasing an updated appliance sometime soon.

Also can you please share what config you used re MIBs on Ubuntu? As Ubuntu is based on Debian (as TurnKey is also) whatever config you have for Ubuntu should also work on Debian.

Don Maker's picture

In /etc/snmp/snmp.conf

 

mibs:/opt/observium/mibs/

 

 

That was it.

 

Jeremy Davis's picture

Hmm ok, so it must just be because it's a newer version of Observium than what we currently ship. We're in the process of upgrading the appliances, so once we have the new version it'd be awesome if you'd be interested in testing that to make sure.

Alternatively if you install the updated version of Observium in TurnKey then it should give you the same result (at least in theory).

Don Maker's picture

I would have been happy to test that for you, but I've already removed that vm. Sorry.

 

Jeremy Davis's picture

Ok, no problems.

I'll try to remember to post back here when we release the new version and if you get a chance it would be great if you could download the new VM and double check. If you can't that's fine too.

Regardless, thanks for trying out TurnKey and giving your feedback.

Post new comment