File Server Appliance: PHP Fatal error:  Call to undefined function SambaDAV\ssh2_connect()

Christian's picture

Installed the fileserver appliance in a container on a ProxMox virtual host. This is the error I am getting:

2017/05/04 14:45:39 [error] 11477#0: *16 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Call to undefined function SambaDAV\ssh2_connect() in /var/www/sambadav/lib/SambaDAV/Auth.php on line 176" while reading response header from upstream, client: XXXXXX, server: localhost, request: "GET /webfolders HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "xxx.xxx.de"

Jeremy Davis's picture

I haven't heard that particular issue reported before so I'm not really sure what's going on there. The only things I could suggest at this point is giving it a little more resources and restarting it. But I'm not convinced that will solve it.

I'm currently working on v14.2 (the next release). And seeing as we're actually migrating to a different web UI for the next release, I'm not too keen to put too much time into trying to work out exactly what your issue is. I will certainly try and have a quick look (or if the new appliance is ready; release it) ASAP.

Thanks for reporting.

Yeknrut's picture

A different web UI? Please tell us more. I just installed the Fileserver appliance and pleased with its operation. Webmin is big and intimidating, so I'm interested in any new UI. Fortunately it doesn't seem like many changes to configuration are needed after installing the Fileserver, just to store and backup a few PCs at home.

Jeremy Davis's picture

It supports allowing all users to access their files via a web browser (log in using Samba user and password). So it doesn't supplant Webmin at all.
Christian's picture

Hi Jeremy, it seems to be some dependency issue. But if a new version is around the corner, don't bother. What's the time frame for the new release?

Jeremy Davis's picture

I hope the updated appliance is done soon. But I can't give you a firm ETA. I'm not currently working on it myself, and after spending a brief time on it, it wasn't anything really obvious to me (so I handballed it).

Regarding your hint about a missing dependency. I just did some quick googling and it seems a common cause for similar issues is missing "libssh2-php". Perhaps see if that's installed (and if not install it)? Certainly shouldn't do any harm...

Post new comment