Thomas's picture

Hi, I am getting following error and have been stuck here:

root@fileserver ~# net ads join -U domainadmin
Enter domainadmin's password:
Using short domain name -- DOMAIN
Joined 'FILESERVER' to dns domain 'FQDN'
No DNS domain configured for fileserver. Unable to perform DNS Update.
DNS update failed: NT_STATUS_INVALID_PARAMETER

Searched through many sites and tried numerous attempts without any luck. I have followed the Troubleshooting Samba Domain Members guide to the tee and no go:

  • Added file server IP addresss and FQDN to /etc/hosts file:  "192.168.1.16 fileserver.domain.example.com fileserver"
  • Manually added an A pointer on the DNS server
  • Tried both "Secure" and "Nonsecure and secure" settings in DNS Dynamic updates
  • Ran dcdiag DnsDynamicUpdate test on AD DNS server and tested successful
  • checked IP address of the DNS server is in /etc/resolv.conf

How do I troubleshoot this?

Forum: 
Thomas's picture

Issued resolved. Problem is in /etc/hosts file. The server IP was added to bottom and loopback address not removed. The etc/hosts file after creating the Turnkey File Server LXC container is as follows:

127.0.0.1 localhost
127.0.1.1 fileserver

#Required for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
# --- BEGIN PVE ---
192.168.1.16 fileserver.domain.example.com fileserver
# --- END PVE ---

Comment out loopback address like "#127.0.1.1 fileserver" and all is good.

Jeremy Davis's picture

Sorry I wasn't able to assist you sooner, but great to hear that you managed to resolve it.

Thanks tons for posting back with the solution too! I'm sure that will help others in the future.

If you have any other feedback on things that we might be able to do to improve any of our appliances (or any more issues) please feel free to start a new thread.

FWIW I try to respond to new posts at least daily, but sometimes I'm a bit slower. On the odd occasion I do miss posts though. So if you don't get a timely response, please feel free to bump your thread (I know it's generally not acceptable/desirable behaviour on many forums, but we don't mind). Unless your bump contains additional info, I'll often delete bump posts when I respond.

Good luck with it all and I hope that TurnKey is working well for you! :)

Thomas's picture

Jeremy, thanks for the quick reply. It is much appreciated when you are in a bind and looking for help.

I missed this the last time... buried in the Samba documentation, "On debian related systems you will also see the line 127.0.1.1 hostname in /etc/hosts, remove it before you install samba". See Setting up Samba as a Domain Member under Local Host Name Resolution section.

Jeremy Davis's picture

It's good to know all this stuff and I'm sure you post will assist others in the future.

Ideally I would love to make it easier to join the fileserver appliance to a domain (rather than running it standalone as it's currently designed). As you've noted it is possible, but a super easy "TurnKey" solution would be ideal! :)

Also as an aside, I have tweaked your user account so you should avoid most of the spam filters now when you post.

Add new comment