LukeKFrost's picture

Good Morning All,

I have just installed the Lamp Stack from a ISO image onto a physical machine to hoepfully use.  Everything seems to have installed correctly in terms on the screens that i am seeing on the screen however when i go to any of the web addresses detailed on the initial screen from a client machine the pages do not load and i get a tiem out error on the screen.  This is the same for all of the different addresses on different ports.

I have also tried doing a standard ping to that ip address from within the network and its not returning anything at all.  

Furthermore i have tried with static and dynamic IP addresses and still getting the same issue.  I tried this as when i try and do an install security update i get an error failing to resolve the name. 

Can someone please help me with this.

Thanks in advanced


Jeremy Davis's picture

My initial guess (and probably wrong) was that perhaps our ISO doesn't include drivers for your ethernet device? However, I don't think that's the case as I would expect you to immediately get an error when trying to configure the network.

So it's likely something else. Or perhaps there are more details to your experience that are worth sharing?

By default, an ISO install will try to get an IP via DHCP. Assuming that you have a DHCP server on your network (and if you don't think so, then it's probably provided by your router), then the default IP the server gets should "just work". If you didn't get an IP assigned by DHCP and got some sort of error, please share the error that you received.

If you did get an IP via DHCP and it didn't work, then there is something wrong with the configuration of your network (i.e. your LAN, not the server network config). The issue is most likely with your DHCP server and/or the way you have assigned IP addresses.

What may be happening is an IP address clash. I.e. the DHCP server has assigned an address that another computer on your network is already using. That can happen if you have more than one DHCP server on the same network, or if you set a static IP for a machine within the IP range managed by DHCP. Either way the DHCP server handling the IP request from TurnKey thinks that the address is free (because it hasn't assigned it) but in actual fact, it is already in use.

If you have more than one DHCP server, then I suggest that you disable one. Often DHCP servers also provide the ability to act as a relay for another DHCP server (thus essentially allowing 2 or more DHCP servers on a single network; as there is still only one DHCP server handling the IP address requests).

If you definitely have only one DHCP, then the best way to resolve an IP clash is to adjust (reduce) the range of IP addresses managed by DHCP and only set static IPs outside of the DHCP managed range. E.g. on my home network, DHCP manages IPs from to (i.e. 50 IPs - which means a max of 50 devices getting IP via DHCP). I then use -> for static IPs for infrastructure (routers, printers, etc) and IPs of for servers with static IPs.

If you have no idea where your DHCP server is (i.e. you haven't set one up) then often it will be a function of your router.

Hope that helps.

Add new comment