Federico Baez's picture


At the moment of raising a new file by means of samba, this has the permission (0764), at the moment of raising a new file via FTP the file has the permission (0644).

Within File Permissions are the following fields
New Unix file mode and New Unix directory mode to both fields set the value 0775.


Federico Baez

Jeremy Davis's picture

It sounds like you understand Linux permissions, and have worked out how to adjust things for your needs. Thanks for sharing what worked for you.

As you appear to know what you're doing, I won't go into any detail on how the octal Linux file/folder permissions work. Others reading along that need more background can find tons of info online (e.g. Wikipedia). However it's possibly worth noting that the permissions that you get when uploading via FTP are default and expected Linux file permissions (i.e. 644 on files; 755 on directories).

TBH, I'm not really sure why the user execute permissions or the group write permissions are added by Samba, although I suspect that's a Windows thing. Although I can see why you may wish to change the permissions to default to allow writing by the group, rather than just the user.

None of us here at TurnKey are regular Windows users. Could you please clarify what issues you hit when the files were 644 vs 775? Perhaps we should consider changing the default permissions for the /srv/storage directory on the filserver app?

Add new comment