Chris's picture

I have created a new Fileserver container and am having trouble getting to a login from the Windows file browser. Here is what I have done so far to set everything up.

  • Created the LXC container and populated it with the TKL FileServer (v15.0)
  • Configured the FS from SSH
  • Logged in as root from the Webmin
  • Created Debian user (for demonstration purposes, we shall use the U/N "bob", password "12345")
  • Assigned "bob" to the "users" group
  • Converted Debian "bob" to Samba "bob"
  • Set Samba "bob"s password to 12345
  • Created a share with the correct permissions (bob:users)
  • Disabled and re-enabled the network adapter on my Windows machine(s) (I have tried this on multiple machines and had the same result)
  • Attempted to access my TKL Samba share at
  • Attempted to login with the correct username and password in the Windows Security Enter Network Credentials dialog box
  • Repeated Failure

Can someone point me in a direction I need to look to fix this? I had a TKL Samba instance up and running (very well) before but had a catastrophy and now I am recreating everything from scratch.Any help is appreciated before I pull out the rest of my hair.

Chris's picture

Ifound my issue. Simply needed to restart the Samba service. Bonehead move on my part!

Jeremy Davis's picture

No worries Chris! It happens to the best of us! :)

Thanks for posting back though regardless. It might help someone else say "Doh!" a little sooner! ;)

Add new comment