Elkfife IT's picture


I have just installed the virtual appliance as a Hyper-V VM and am configuring it for testing.

I have uplaoded various images to customise the look and whilst they appear to upload ok they just show as broken links on the dashboard - any idea what is causing this?


Thanks in advance...



Jeremy Davis's picture

I've just had a look at the code and it looks like it might be required to set the domain that it's being served from. We set it to localhost and that seemed to work fine. So my first guess is that the missing pictures will have a URL that starts with 'http://localhost'.

If that's the case, then please try setting the domain. If you're just testing and using a IP to connect to your instance, then you could input the IP instead. Use 'http' if you're running it locally and don't want to worry about TLS certs. If it's publicly available via domain, then set 'https' (and get a free Let's Encrypt TLS cert for your domain via Confconsole if you want).

You can set the domain like this:

sed -i "\|APP_URL=|s|=.*|=$YOUR_DOMAIN|" $CONF
systemctl restart apache2

Hopefully that fixes it?! Let me know how you go.

On the assumption that I'm right, I've opened an issue on our tracker. But please post back to confirm.

Elkfife IT's picture

Hi Jeremy

That worked a treat - thanks so much.

We are only testing so just set the domain to the internal IP address and all images  now showing perfectly.





Randev Ranasinghe's picture

Can you tell the file location and file name to edit


Thanks in Advance

Jeremy Davis's picture

The info is in my previous post. You can copy/paste that into a root user SSH session (or run 'sudo su -' first if not logged in as root).

If you'd rather manually edit the file, the file to edit is 'CONF' value ('/var/www/snipe-it/.env'). And the setting to update is 'APP_URL=' (add your domain after the '=').

You'll need to restart the webserver (Apache) afterwards too.

Add new comment