Beary16's picture

1. Install a Turnkey Media Server container (Check)

2. Installed Debian VM (Check)

3. Mount network share between Media Server container and Debian VM 


I need a step-by-step guide to do step 3.


Im sorry this is a very newb way to go about this, but Ive been working on this for days. Once I get it to work at least once, I can do it from then on. Ive used every youtube video and online resource with no luck.


Beary16's picture

To narrow it down, I'm able to log in via the smbclient. Mounting it is the problem. I am using promox. Maybe its the container settings?


Beary16's picture

All im trying to do is create a Debian VM so I can download my torrent files to it, so when the jellyfin server is pointed to the Debian VM network share,  I can stream from it.

Thats it!



Beary16's picture

smbclient // -Uroot

Works fine!

mount -t cifs // /mnt -o username=root,password=PASSWORD

"mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)"


Ive tried this 10 different ways using Tutorials and Youtube, and this is the reponse I get most of the the time.


Beary16's picture

Well finally figured it out.....PASSWORD CHARTERS.

Jeremy Davis's picture

Glad to hear you sorted it out. Although I assume you mean password characters?

Do you know what the actual cause was? Did you just have the cap lock key enabled on one machine but not the other? Or were you not using a US-International keyboard with some special characters (that render differently)? Or did you use some specific character that didn't work?

In other words, is there something that we could change and/or document better to make it easier for others in the future?

Regardless, personally, I would suggest that using a Windows file-sharing protocol (SMB) to share files between Linux machines is not ideal from the get go. My personal preference is SSHFS (filesharing via SSH), but there are other options (SFTP, NFS, probably others). Also if your Debian VM is also running on the same Proxmox host, then I'd run that as a conatiner too and probably the best way to go is to create a storage directory on the Promox host and share that with both containers, then there is no network file-sharing involved at all...

Anyway, as I say, glad to hear that you worked it out and you have it up and running.

Beary16's picture

Thank you for a well written explaination. 

What I found with the password characters, is the password I was using had an "&" in it. So I assumed all special characters are not allowed in the samba config. If you want to replicate this error, you will see what I mean.  Maybe its only the "&" character? Now the password isn't near as safe, but it works.

Everything I use is in Proxmox, so the quickest and easiest way to share folders is what I'm after. Creating a storage directory on the Promox host and share that with both containers is ideal. But  I need a GUI for alot of the tasks Im trying to do, primarly access to webpages.

Anyway, thanks for your reply. I look forward to creating many Turnkey containters, so I'm sure I will have 1000 more questions :D


Jeremy Davis's picture

I'm not quite sure what the issue may be, but I just tested a server using a password that included a '&' character (created via <shift> <7>). I tested from my (Debian) laptop using smbclient and also tested login via WebDAV-CGI (the web UI included via port 443) and both worked fine for me?! Are you using a standard US-International keyboard? If not, then I reckon that's the issue. If it is, then can you recall if there were some other "special" characters that I can test?

Well assuming that it works, then SMB should be fairly quick and relatively easy, but as I say, assuming that both are containers, then a host directory shared between specific containers (via container bind-mount) is probably going to be the best IMO. But whatever works for you! :)

Good luck with it all and please ask any questions you have and I'll do my best to answer. Also, if you have other feedback and/or ideas on improvements we could make, please share.

Add new comment