bhruska's picture

I tried searching forum for info on installing/upgrading VMware tools on Exsi and they all seem dated.

Is there a simple way to install VMWare tools?  vSphere gives me an error doing it the regular way, so I'm just looking for a little guidance.

I've got some wordpress appliances.  


Jeremy Davis's picture

I'm not sure what the "regular way" is? But if you install for our OVA, you should already have open-vm-tools installed. We install it from the Debian repos (i.e. via apt). The current default version in/for v16.x is v10.3.10. So if you installed from an ISO and are ok with that version, then you can install like this:

apt update
apt install -y open-vm-tools

If you want to upgrade to a newer version, then the easiest way is to use Debian backports. Currently v11.2.5 is in buster-backports. To install that (from a v16.x Turnkey server):

mv /etc/apt/sources.list.d/debian-backports.list.disabled /etc/apt/sources.list.d/debian-backports.list
apt update
apt install -y -t buster-backports open-vm-tools
bhruska's picture

So I did apt install, and it says its installed.  Wonder why vSphere isn't seeing it.  When I try to upgrade or install it I get a message saying "The Operation is not supported on this object".  And I can't load it via the right click on VM option either.  Strange.  

Is there anything I have to do to "start it" automatically?



Jeremy Davis's picture

Looking at the package contents I can see a open-vm-tools.service file (/lib/systemd/system/open-vm-tools.service). So it appears to have an associated service. Perhaps double check that that's running?:

systemctl status open-vm-tools.service

If it's not running, perhaps try (re)starting it?:

systemctl restart open-vm-tools.service

I'm not at all familiar with vSphere, but looking closer at your screenshot, it appears to be more of a warning rather than an actual error? (Although I can see the error message down the bottom that you are referring to).

Are you actually experiencing any problem when working with the VM? From your screenshot, it's not clear to me that it's not seeing VM tools and/or there is a problem with vm-tools?! It just appears that the guest version of vm-tools doesn't match the host version (probably older in our VM). In the table, it says that it's "Guest managed" (which would make sense as it's installed inside the VM via apt rather than installed by the host). It sounds like you tried to "update" it and it failed (as per the error message; which again would make sense - as it's "guest managed").

Regardless, assuming I understand correctly, I see a few possible paths:

If it doesn't actually cause any real issues when working with the VM (or you are willing and able to adjust your workflow to workaround vm-tool issues), then you could just ignore the version warning you see in your screenshot.

If you are actually experiencing functional issues with open-vm-tools from our appliance within VMware, then the newer open-vm-tools version (in buster-backports) might resolve them? It likely won't remove the vSphere version warning (depending on how specific the version comparison test is and how closely it matches the host version). I would expect that while vm-tools is "guest managed" in your TurnKey VM, updating from the host will continue to fail.

If you want to manage it all via the host, then I imagine it's possible to install from the host (will almost certainly require removal of the ones we ship). I have no idea how that is done, but I assume that you have some idea (or can find out). Remove the version we ship with like this:

apt purge -y --autoremove open-vm-tools

Hopefully that helps?

bhruska's picture

I'm not experiencing any functional issues, but I'm looking at upgrading the VMware installation and VMs via vSphere to keep up with latest releaes.  So trying to use their Updates functionality, which I've never used before.  Probably something with Vmware 6.7 I haven't figured out yet.  

It does appear to be running the version you installed, so it weird I can't interact with it through vSphere perfectly.  

Thanks for you thoughts.  I'll keep plugging on it.



Add new comment