Witzker's picture

Hi, tried to start a VM in Workstation and in ESXi with this ISO https://www.turnkeylinux.org/download?file=turnkey-nextcloud-17.2-bullse... But It does not Boot! What have I done wrong?

Jeremy Davis's picture

Firstly apologies on my slow response. I've been away and am still trying to catch up...

Can you please share some more info about the boot failure? E.g. at which step it fails, any error messages that are displayed, etc. I would expect it to work, but without any more info about where it is specifically failing and/or specific error messages it's really hard to even guess what might have gone wrong.

I know that posting screenshots is a pain on our forums, but you can attach them to your original post (let me know so I can then edit your post to include the screenshot).

Unfortunately, I don't have a copy of ESXi but I tested the ISO on current VMware Workstation Player (17). The Nextcloud v17.2 ISO boots fine and the first part of the install works fine. I did hit an issue with the grub install step (known intermittent issue - trying to find the right volume to install grub to) but I worked around that by choosing the "manual" option and manually entered '/dev/sda' and otherwise it worked as expected.

Moving forward, I can only suggest that you double check your set up and that you are definitely trying to boot from the ISO (not from an empty vHDD). Also it might be worth double checking the checksums for your downloaded ISO and/or redownloading it, just in case your local copy is corrupted. Another idea for testing would be to try the ISO with some other VM platform. VirtualBox is free/open source and has an installer for most common OS (Windows, Mac and Linux) and it should definitely work on that. It should at least confirm whether it's the ISO of ESXi (and/or ESXi config).

Witzker's picture

THX for your response

When I open the downloaded ISO on Windows, I have no boot files in the root

When I put the ISO in Rufus and make a bootable USB stick, there are files in root.


Ad said before, I'm a user and don't know if there also has to be files in root for VM ware to boot from the ISO.


I have used the core ISO several times without problems, before, so ??

Witzker's picture

I cannot edit the posts!

And no way to attach photos

When I boot from ISO, it says "No media"


Witzker's picture

As suggested long ago To Pls. Do a OVA for discourse and also use this as your forum.

or just setup this to have up-to-date forum


What do you think?

Witzker's picture

The boot problem was my fought.

The Firmware to boot must be BIOS, not EFI!!

Worx great THX for this edition!!


The only Problem I face now is to get My.Domain.com to the VM.

I just changed the IP I had before to link to the old Nextcloud to the new one

But I get Bad Gate way.


I renewed the Lets encrypt certificate, It worked but next day again Bad Gateway.

The certificate which is shown in the browser is localhost, and I think this is not the one from Let's encrypt.?!?

Is it possible that there is a certificate coming with the ISO that blocks the new one from Let's encrypt?



Add new comment