Jon Bennell's picture

So, I've been a silly boy and tried updating webmin from within itself. This resulted in it being completely broken.

So I ran these commands at it now responds on port 10000 (previously 12321)

apt-get remove webmin
apt-get update
apt-get install webmin

However now the interface looks like 1990 and when I try an update it from 1.831 to 1.840, I get a mess of buttons no matter which web browser I use. I then have to remove webmin and install it again.

Any tips on how I can get it back to where it was, before I got curious and burned my fingers please?

I'm particularly missing the web based file manager and text editor :(

Thank you,



Jeremy Davis's picture

We package Webmin ourselves, with the modules individually packaged. They all depend on the base package (webmin). So when you uninstalled it, you also uninstalled all the modules.

You can update to the latest version. But installing over the top is not a good idea.

If you'd like to try to restore your current Webmin to functioning standard, using our (a bit out of date) packages, read on. If you'd rather install latest upstream, that's covered further down.

Restore TurnKey Webmin

As I noted above, you only have the base webmin package installed. So you'll need to know the other webmin package names that we ship appliances with by default. The list for core can be found in TurnKey's base package plan. FWIW it's probably webmin-theme-stressfree missing that makes it look 1990! :) If you're running a LAMP (or LAMP based) appliance then you'll also probably want to install webmin-apache, webmin-mysql & webmin-phpini (from lamp plan).

FWIW if you want to see other modules available, try running this:

apt-get update
apt-cache search webmin

Keep in mind though, many of the modules that we don't use by default will also require you to install the software that they control. E.g. installing webmin-dhcpd won't also install a DHCP server by default, you'd need to explicitly install isc-dhcp-server too.

Install latest Webmin (from upstream)

If you want to install the latest Webmin, I suggest that you completely uninstall our packages. You may be able to get away with leaving our config, but I can't be sure. To leave the config, use apt-get remove (as you did before). To totally wipe out the default config (no going back), use purge:

apt-get purge webmin # no going back...
Then install Webmin as per the upstream Webmin Debian instructions (TurnKey is Debian under the hood).

WRT connecting to it, the easiest option is use Webmin's default; 10000. You should also remove the Webmin section from the stunnel config. It should be /etc/stunnel/stunnel.conf or similar. Then restart stunnel:

service stunnel4 restart

If you're behind a firewall or some sort of NAT, then you'll need to adjust the ports too (allow 10000, disable 12321).

Add new comment