How simply upgrade Adminer in Wordpress Turnkey Package?

yard's picture

Hi I have trouble with Adminer 4.2.5 in Turnkey Wordpress bundle. Look here:

https://screencast-o-matic.com/watch/cFn1ijogmQ

when I need delete tables, then browser screen is strange flickering

How can I simple update Adminer to newest version?

 

 

 

Jeremy Davis's picture

I haven't seen that before. I'll see if I can reproduce that sometime soon and report back.

We install Adminer from the Debian repos (jessie-backports in the case of v14.2) so there isn't a super easy way to update to a newer version in a stable way. The only thing I could recommend is removing the currently install and then manually installing as per Adminer website instructions.

Having said that, I'd personally try a different web browser first. It may also be worth trying in a private/incognito session as well. Perhaps you have some plugin/extension which is interfering with some javascript on the page or something?

Jeremy Davis's picture

Thanks for reporting this issue. I have just fired up a WordPress server and can reproduce your issue (FWIW I'm using Chrome).

When I first tried, I couldn't reproduce it, but I realised that it depended on where my cursor had been previous to trying to click on the "drop" button. I tried working out how to make that work reliably then inadvertently discovered that if you scroll down slightly (resize your browser window to be smaller if you can't scroll down) then it stops jumping around.

I'll try to figure out what is actually causing this, whether it's something to do with our configuration, or something to do with Adminer specifically.

Jeremy Davis's picture

[IMPORTANT UPDATE] I have just realised that I think the issue is actually with the theme that we provide for Adminer, rather than Adminer itself!

Please ignore this post and refer to below comment for updated info.


I just noticed that Adminer v4.5.0 is now in Debian testing (currently Buster). I have just tested it out and can confirm that it resolves the issue you have reported.

You could in theory add the testing/buster repo and pin the package, but after having a look at that, I don't advise taking that path. The new package also has newer dependencies. So it will either fail to install, or worse still, it will pull in a ton of packages from testing. Definitely NOT what you want on a production server!

However, there is another hacky way to force installation of the newer version. That is to adjust the dependencies of the newer package to fit with the rest of your (Jessie based) v14.x TurnKey server. Again this is not generally recommended on a production server, but I have done a little research and believe it's unlikely to cause any damage. Worst case scenario, it may break Adminer in future releases.

So, to download the package and adjust the dependencies:

# make temp dir and install tools needed
mkdir ~/temp
cd ~/temp
apt-get update
apt-get install binutils xz-utils

# download and unpack the deb
wget http://http.us.debian.org/debian/pool/main/a/adminer/adminer_4.5.0-1_all.deb
ar x adminer_4.5.0-1_all.deb
tar xf control.tar.xz

# modify the deb's dependencies and repack
sed -i "/[Depends|Recommends]/ s|php|php5|g" control
tar c md5sums control | xz -c > control.tar.xz
ar rcs adminer_4.5.0-1-hacked_all.deb debian-binary control.tar.xz data.tar.xz

# install new deb
dpkg -i adminer_4.5.0-1-hacked_all.deb

# clean up temp dir and tools
cd ..
rm -r temp
apt-get purge binutils xz-utils

Note that you will not get any updates for Adminer via apt after you do this. I strongly suggest that you regularly check for updates. Testing does not receive security updates, just new packages.

If/when there is a new package, and you wish to update, please browse to the Adminer buster (currently testing) download page (here) and download the latest version from a mirror near you (you can use the url from the mirror to adjust the wget line above if you wish). Then repeat the above steps, substituting the new package version name.

Jeremy Davis's picture

Actually, I'm not sure at all now...

After installing the newer version then reverting to the original version I can confirm that the issue is resolved. However, I can't for the life of me, work out what has changed. It's now working fine, but something is different?!

I'll need to dig deeper next week sorry...

Post new comment