Stephen Hill's picture

For the life of me I can't seem to figure out the default username for Adminer.

I've tried 

Root, root, Admin, admin, Homestead, homestead, adminer, Adminer, Turnkey, turnkey. 


What am i missing?




Jeremy Davis's picture

As noted under the "Usage details & Logging in for Administration" for each appliance, e.g. LAMP, for v15.0 the default "root-like" MySQL/MariaDB Adminer user is 'adminer' (no quotes).

Although I note that you stated that you have tried 'adminer', so perhaps you are using a PostgreSQL based appliance? The PostgreSQL "root-like" user is 'postgres' (again, as noted under "Usage details & Logging in for Administration" e.g. LAPP).

If you continue to have issues, perhaps try resetting the 'adminer' user password via the commandline by rerunning:


Or to reset the password for 'postgres' user on PostgreSQL appliances:


Hope that helps.

I don't know why the LXC is causing so many problems...

I recently installed magento LXC on my proxmox and on first boot it asks me for a different admins password including adminer. Then when I try to access it through the web console, it tells me that the password is incorrect.
Another problem I have is that Apache doesn't work for me, neither does webmin...


In web browser show: An error has happened during application run. See exception log for details.


In console: Starting webmin (via systemctl): webmin.serviceA dependency job for webmin.service failed. See 'journalctl -xe' for details.

after exec journalctl -xe show:

The unit stunnel4@webmin.service has entered the 'failed' state with result 'exit-code'.
Dec 13 16:47:31 store systemd[1]: Failed to start Universal SSL tunnel for network daemons (webmin).

I have already tried riding the LXC as non-privileged and privileged... and in both cases the same thing happens to me... I don't know why there is so much problem.

Jeremy Davis's picture

I don't understand either. It "just works" for me on my local Proxmox instance.

The only thing I can say is that in my experience, an unprivileged container is preferable. Beyond being better isolated from the host (and therefore safer), the services should all "just work". What you are reporting is expected behavior with a privileged container (unless you also enable "nesting" - which has further security implications). That is because most of the services in Debian have been security hardened, which depend on some specific options that are not supported by privileged containers (unless "nesting" is enabled).

When you say you tried it both privileged and unprivileged, were they clean installs from the template? Or did you modify the guest to change from privileged to unprivileged (or vice versa)? If it was the latter, I suggest that you retry launching a new unprivileged container from scratch - just to be sure.

Once you've done that, the next step I'd recommend before you go any further, is checking that there are no failed services, like this:

systemctl list-units --failed

As per your post, on your current server, you'll likely see Apache, Stunnel and probably MySQL/MariaDB have all failed as well. Probably others too...

To investigate further, you'll want to view more info about the service. I'm guessing you already know this next bit, but for completeness, you can get a bit of an overview of a specific service via systemctl too. E.g. you noted stunnel4@webmin.service failing - to view more info:

systemctl status stunnel4@webmin.service

You can also view more extensive log entries via journalctl. I.e.:

journalctl -u stunnel4@webmin.service

You can also try restarting the service:

systemctl restart stunnel4@webmin.service

Although my guess is that if it's not starting, then it won't restart either.

FWIW, if the issues are being caused by LXC/systemd incompatibilities, then look for mention of "namespace" problems in the journal. E.g. to check for any "namespace" issues:

journalctl -b | grep -i namespace

I suspect that the Adminer sign in issue is related to MySQL/MariaDB failing to start (hence either the initial setting of the password and/or the validation of the password is failing). Although if Apache is failing too, then Adminer shouldn't be working at all!?

To summarize, I'm not surprised that you are seeing this in a privileged container, but I do not understand why you're hitting the same issue(s) on a unprivileged container. For me it "just works".

If you'd like more assistance, please share more info about which service(s) are failing and the relevant logs. Please also share which specific appliance and the specific version, as well as your Proxmox version. That way I can test myself, matching your environment as closely as possible and double check that there isn't something version and/or appliance specific that I'm missing.

Add new comment