I'm trying to install version 14.2 for an archive our websites which require older versions of PHP. When I run the install it go straight through until I get to this prompt and the keyboard is not responding. Something about rescue mode. I'm not getting the normal setup screens for the IP address or the passwords. Please see attached image.
Regards Paul


The message is as follows.

Welcome to rescue mode type "systemctrl default" or ¬D to enter default mode
type "journalctrl -xb" to view system logs or "system reboot" to reboot

Anyone got any idea what's going on

Jeremy Davis's picture

And where are you installing to? Some sort of VM environment I assume?

The reason why I ask, especially if you're installing from ISO, is that our installer (aka di-live) runs in rescue mode. FYI, rescue mode aka single user mode, is starting state where only a bare bones "root user only" system is running, with only the required services. So if you are installing from ISO, it being in "rescue mode" isn't super weird in and of itself (although clearly things aren't right...).

OTOH, if you're using some other image (e.g. the OVA VM build) then it should never start in rescue mode and so would be indicating something is really seriously wrong.

If booting from ISO, have you checked to see if the "live boot" functionality works? If that also doesn't work, then my first guess would be data corruption. Assuming an ISO, you can check for corruption by downloading the relevant hash file from the mirror. It's a text file which includes the hashes and instructions on checking them.

Installing as a hyper v generation 1 machine. I've done this many times with turnkey and I also use the hub backup.

If I run the live CD demo option it works okay I can get to the root password set up so unlikely to be a corrupt iso.

When I tried to install it briefly halts at this prompt for couple of seconds.

[....] starting di-liveGive root password for maintenance
(or type control=D to continue)

Not sure if it is relevant but there isno space between di-live and Give

It then continues until I get to the other prompt about rescue mode the cable becomes unresponsive.

Jeremy Davis's picture

Unfortunately, I'm unfamiliar with Hyper-V, but as you note (and has been reported by others) it should work fine as a Hyper-V "Gen 1" VM. So I'm not really sure how helpful I'm going to be... :(

As you note, the fact that the Live CD option works ok, does seem to suggest that corruption is unlikely. Although as I note, it's pretty easy to check, so might be worth doing anyway? Just find the relevant hash file on the mirror and compare the included hash against the hash of the ISO. FWIW, apparently (according to my google search) as of Win7, Windows includes a commandline hash checker. I haven't tested (as I don't have a copy of Windows handy) but apparently, it works like this:

CertUtil -hashfile YOUR_FILENAMES MD5

(Where YOUR_FILENAME is the name of the ISO file in this case).

Re your note about the output to the terminal:

[....] starting di-live
Give root password for maintenance
(or type control=D to continue)

That's (sort of) expected. In my experience, there should be a line break between them, but otherwise it's normal (not sure if there is any significance of no line break?).

FWIW the '[....] starting di-live' is systemd, noting what it's up to (i.e. starting di-live; our debian-installer wrapper that formats, partitions, etc and installs the live system to the HDD). The "Give root password for maintenance (or type control-D to continue)" bit is the "single user mode" (aka "rescue mode") log in prompt. It automatically pops up once the base system is up and running; as a normal log in prompt would show in "multi-user mode". Under normal circumstance, di-live should start very soon after that and you should be good to install (although obviously not in your case).

The fact that it's getting that far, but then failing is a bit weird IMO. If it was an issue with (lack of appropriate) drivers, etc (i.e. something specifically related to Hyper-V) I would expect it to fail much sooner, or possibly later; on the first boot after installing?!

One way you could try working around it is to try manually installing from the live system. I.e. boot into the live system, run through the first boot scripts and then once you're in, run:


IIRC there were some weird bugs in v14.x di-live when running from the live system, but I'm fairly sure that the basic install should work ok. If you have troubles partitioning/formatting, I suggest trying both with LVM and without - one of them should work; the manual partitioner was broken IIRC.

Even if that doesn't work, perhaps it might give some more useful output on what is going wrong? Probably some sort of error message, most likely a python stacktrace? If so, please share that if you can and maybe it may give some insight?

If you're getting desperate, then there is also another hacky potential work around. I can't guarantee that it will work for you (especially considering that something weird is already going on), but perhaps it's worth a shot if you have the time and patience?

The hacky workaround is to manually format the HDD (either from the live CD; or any other Linux live CD for that matter) and then rsync the contents of /rootfs (from the TurnKey live system) to the new partition you've created. You'll also need to install grub and IIRC manually create an /etc/fstab file. It'll be a PITA and will require a bit of time and patience and probably a lot of googling, but otherwise it should work. FYI, that's essentially all di-live does!

As a bit of an aside, I know that can work as I have done it before myself. It was years ago, and a different version of TurnKey but it worked. It was when I first moved from Windows to Linux on my laptop. I wrote a v12.0 TurnKey Core ISO to USB, but (for reasons I forget now) it wouldn't boot from the USB (and my laptop doesn't have a CD drive). I forget the exact process, but I used a live system (that would boot) to manually partition and copy across the contents of the USB's /rootfs dir to the freshly created partition. I then chrooted into the new rootfs (on my laptop), installed grub (from the running live system) and rebooted. I recall I had to muck around a bit with drivers to get wifi working (no NIC either) then installed Gnome to get a (somewhat) "normal" desktop system and all was well. And still is - I'm writing on it right now! :)

Booting into the live system then setting up the passwords gives you access to the advanced menu and there is the option to install to hard disk. Use this option and install went through okay without problem so machine up and running.

Thanks for help appreciated.

Jeremy Davis's picture

Thanks for letting me know. Apologies on my rambling... :)

Add new comment