nurbles62's picture

I downloaded the 15.1 ISO so that I could use the live boot to see it things work as I need.

I have tried several times, but I cannot get beyond any attempt to configure eth0.

If I choose DHCP, it just hangs forever (well, up to 20 minutes is all I've actually given it, but that is far too long.)  It should fail (or succeed) reasonably quickly and let me know the result.

If I choose STATIC and fill in all of the fields as they are set by the Ubuntu system that I wish to replace (that currently boots and works from the hard drive in the machine I am using to test the TurnKey LiveCD) then I am presented with a message that is either poorly formatted and/or in slightly broken English that, I think, is trying to tell me that I did something wrong.  The message shows me the (correct) settings I entered and also offer a choice of static or dhcp again.  If I choose DHCP, it will hang until rebooted and if I choose STATIC, I end up back on the same message.  I gave up and came here after about 20 cycles of this.

So far, I have a rather low confidence level in this product.

Jeremy Davis's picture

What hardware are you installing to?

My guess is that either it's relatively new(ish) hardware and/or it requires non free hardware drivers!? I say that as you more-or-less state that "Ubuntu works fine". AFAIK Ubuntu provides non-free drivers with their ISOs and assuming a newer release, it would also have newer firmware bundled.

It might be worth trying our Core v16.0rc1 ISO and see if that fares any better...? I'd be interested to hear how that goes if you have a chance.

It's perhaps also worth noting that 90+% of our users are running TurnKey in some sort of VM. Bare metal installs are incredibly rare (mostly getting the last bit of life out of old hardware). Unless it's particularly low spec hardware or your intended usage is particularly intensive, I personally think that installing a headless server to bare metal is a waste of resources anyway.

I install a hypervisor to bare metal, then install TurnKey on top of that. My hypervisor of choice is Proxmox VE. TurnKey LXC containers are available for download via the UI. Or you can install to a "proper" VM from ISO.

nurbles62's picture

The computer is 10+ years old (that's why it is available).  lshw shows the first NIC as D-Link RTL8139 and the second as ADMtek NC100 Network Everywhere (the box said Linksys.)

I went back to Ubuntu 18.04.4, followed the partially complete instructions in Ubuntu's OpenVPN Guide and then managed to figure the remaining parts on my own.  In the end, I have a bridged OpenVPN that is working perfectly for my needs (which probably will not extend much beyond the COVID-19 stay at home restrictions.)

Jeremy Davis's picture

That's strange!? According to the Debian Device Database (TurnKey is built on top of Debian) both of the devices you noted should "just work" out of the box... TBH, my guess is that they may just not be available for the "Live boot" component and would have worked fine if you'd actually installed it (the live boot component uses a fairly slimmed down custom setup). But I'm only guessing and I certainly understand your apprehension in that regard.

Not that it's probably of much consultation to you now, but in our upcoming release, the Live system is rebased back on default Debian (we still have a customised live installer, but the live system itself is default Debian).

Anyway, I'm sorry that TurnKey didn't work for you. Thanks for the feedback and I'm really glad to hear that you got yourself up and running with what you needed. Thanks anyway for trying out TurnKey and good luck with it all.

Keep safe and take care in this crazy world...

Add new comment