Richard Hillsdon's picture

I have loads of containers running under Proxmox for many years with no issues, have tried recently to add a load more LAMP containers, and can't get any of them to work, despite doing the same setup I have always done which usually takes 5 minutes.

Half the time now after I install it when I try and login as root it tells me the login is incorrect, which it isn't as I have just typed it into the setup!

Then when it does install and let me login (using the same password) I see when it loads up that it says it fails to load Apache2 due to a permissions fail, and then none of the web based services work at all, so I can't do anything useful with it.

Never had these issues before, since the installer sets up the whole machine itself, how can it not have the correct permissions and what can I do to get a clean container install of LAMP like it always used to be in a couple of minutes.

Is the LAMP installer template corrupt?


Jeremy Davis's picture

As you may have noticed, we've been having some issues with the website (and our mailserver too). I'm pretty sure I've got it under control now though...

In answer to your question, my guess is that your new containers are "privileged" (and the old ones are either an older version - with less security hardening, or are "unprivileged").

Why Apache fails in a "privileged" container is because of some service hardening that has been done in recent times, is incompatible with a "privileged" container config. You can modify the settings (within the apache2.service file - i.e. remove the security hardening) to get it to run, but it's usually easier to just ensure that the "unprivileged" box is ticked when creating your container!

I'm not sure about your root password issue, as that component (when launching an LXC container) occurs within Proxmox. Although are you using a US international keyboard? That is what TurnKey requires by default. If you use an alternate keyboard and created the password in the PVE webUI and included some special characters in the password, then that might explain it failing when logging in via SSH (your web browser would interpret your password correctly, but then the SSH session will assume a US International keyboard).

Add new comment