L. Arnold's picture

So I just tested with the same Odoo image as well as the same Backup set.

I can restore to a ISO created Linode server.
I just installed Virtual Box however (and also did an update to current)

When I install the current OVA install, everything installs but when I go to run a restore I get:

Any thoughts as to why?  Is it something to do with Virtualbox being behind NAT or something similar?  I suppose I could install from ISO but was hoping to save some time with the OVA install.
thank you.


Linked TKLBAM to your Hub account.

Downloaded turnkey-odoo-16.1-buster-amd64 profile

root@odoo ~# tklbam restore 162

Executing Duplicity to download s3://s3.amazonaws.com/tklbam-us-east-1-deletednumber

y to /tmp/tklbam-7syZVk

===========================================================================================================

========================

// started squid: caching downloaded backup archives to /var/cache/tklbam/restore

# duplicity --archive-dir=/var/cache/duplicity --s3-unencrypted-connection s3://s3.amazonaws.com/tklbam-us-

east-1-deletednumber/deletedhas/tmp/tklbam-something

Last full backup date: none

Traceback (most recent call last):

File "/usr/bin/duplicity", line 1405, in <module>

with_tempdir(main)

File "/usr/bin/duplicity", line 1398, in with_tempdir

fn()

File "/usr/bin/duplicity", line 1332, in main

restore(col_stats)

File "/usr/bin/duplicity", line 637, in restore

restore_get_patched_rop_iter(col_stats)):

File "/usr/bin/duplicity", line 659, in restore_get_patched_rop_iter

backup_chain = col_stats.get_backup_chain_at_time(time)

File "/usr/lib/python2.7/dist-packages/duplicity/collections.py", line 947, in get_backup_chain_at_time

raise CollectionsError("No backup chains found")

CollectionsError: No backup chains found

Traceback (most recent call last):

File "/usr/bin/tklbam", line 46, in <module>

CliWrapper.main()

File "/usr/lib/tklbam/cliwrapper.py", line 88, in main

commands[command].main()

File "/usr/lib/tklbam/cmd_restore.py", line 502, in main

backup_extract_path = get_backup_extract()

File "/usr/lib/tklbam/cmd_restore.py", line 474, in get_backup_extract

ignore_err=opt_ignore_err)

File "/usr/lib/tklbam/duplicity.py", line 182, in __call__

command.run(target.secret, target.credentials, debug=debug)

File "/usr/lib/tklbam/duplicity.py", line 114, in run

raise Error("non-zero exitcode (%d) from backup command: %s" % (exitcode, str(self)))

duplicity.Error: non-zero exitcode (30) from backup command: duplicity --archive-dir=/var/cache/duplicity -

-s3-unencrypted-connection s3://s3.amazonaws.com/tklbam-us-east-deletedID/deletedhas/tm

p/tklbam-something

Forum: 
L. Arnold's picture

expecting you will ask.
I have to install the Init via either Webshell or Webmin as I can't paste the keycode in to Virtualbox for some reason...

Anyway,  I did this to 2 different VM installs.  Same result.

Jeremy Davis's picture

Even when running local VMs (e.g. in VirtualBox) I still use an SSH client to connect to the server (rather than using the VM window directly. That ensure that you can interact with your VM the same as you would interact with a remote server. Anyway...

I hope you don't mind but I reformatted your original post to make it a bit easier to read. I'm not sure why it didn't work properly when you originally posted it. I tried to format it in a code block, but for some reason, that isn't working?! So I just made it normal text...

Regards to the actual issue though, see this line in the stacktrace:

Last full backup date: none

That suggests to me that you did a typo when you put in the Backup ID number. Are you 100% sure that the backup ID is 162? If you are sure that it's the right backup ID, then be sure to push a full backup. I.e. log into the server that is related to the backup ID and run this:

tklbam-backup --full-backup now
L. Arnold's picture

After a full backup I still get "No backup chains found".
It looks to me like something is not passing through, perhaps on account of the network routing and that ultimately the IP on VirtualBox is behind NAT.  The Init Key is working in that I can run backups successfully from the VirtualBox install.

I tested 2 different backup sets to VirtualBox that each had had new full backups per your syntax above.
Failure was the same - you can read one below but they were the same.

And just to be sure, Linode to linode, I did the same restore command with my backup install and it is plugging along as we speak (I will likely need to manually pull the Odoo Database, but that is a separate issue, and I see those errors rolling in now when it is trying to overwrite the database with the same name and general structure - lots of constraint xyz already exists).

Noting the Syntax here for a forced full backup

tklbam-backup --full-backup now

L. Arnold's picture

Sending the picture separately as it (a screenshot) did not post.



 

Jeremy Davis's picture

Hey Landis. I posted the pic for you.

Can you please show me the output of:

tklbam-list | grep ' 162 '
L. Arnold's picture

-Hi Jeremy,
I can't "copy/paste" via the connection but what it shows is:

1  NO    2022-02-16   2022-09-16   3042.67     TurnKey Odoo
 

The instance itself has backed up with ID #172 on 2022-09-14

I thought I would test on that so running.

tklbam-restore 172

Same result

sending via DM.

thanks for helping.

Landis

L. Arnold's picture

So something with the routing on the internal system.  Strange.

I just uploaded to Oracle Cloud a new "initialized" TKL Odoo, and am now running tklbam-restore

It is working in Putty.  I need to get access to the web side still but should just be a few settings.

Fair bit work to get that Oracle connection working, but it is..
So on the local VirtualBox I need to tweak something with the Network, but wierd that it seems to do everything but restore.

all for now.

Jeremy Davis's picture

Hmm, it should "just work", but it does sound like there is some weird routing or proxy config that is interfering with the network traffic?! We have had some limited experience with poorly configured proxy networks messing with TKLBAM, but never that explicit message - that's a new one!

Where are you running VirtualBox? If you're running it on on a Windows host, perhaps there is some weird firewall filtering or something?

Add new comment