L. Arnold's picture

I just verified this on a Hub 17.x Joomla3 install.  I know that it is frequent or always with Odoo installs.

Basically when you set your new server up and assign passwords etc,  Those passwords do not work after the install and you try to login for the first time.

I thought perhaps a further restart was needed, but in this instance, still no.

Good thing system is suggesting and makes it easy to assign a Cert to hub builds.  This does allow Putty Logins.

In Putty, once logged in, command


allows resetting passwords that actually keep.

I am pretty sure I have noted this behavior before but did not find anything in my search.  Probably is reflected in GitHub issues.

Letting you know here, and also thinking some folks may find this helpful if they get into this situation.

Jeremy Davis's picture

Thanks for your persistence reporting this issue. I recall that we did fix something in Odoo related to this some time ago. Unfortunately though, I can't reproduce it with Joomla4?! FWIW I just tested the v18.0 release from the Hub using a 10 char password that contained upper case, lower case and numbers - I suspect that it's a "special" character (e.g. a punctuation mark) that is causing the issue. My guess is that either it is not being interpreted at all, or perhaps being wrongly interpreted?

So I'm guessing that there must be something specific to your password that it doesn't like. Next time this occurs, could you please email me (via support AT turnkeylinux.org) the password that does not initially work. Hopefully with that info I'll be able to recreate the issue on my end and then I can at least flag the non-working character(s) - and we can try to resolve the issue.

FWIW, following a report from someone else, I did test a bunch of symbol characters and all the ones I tested worked (that person couldn't recall the exact password they tried initially, but confirmed that it had lots of symbols/special chars).

Add new comment