Phil B's picture

I've searched all over for solutions but nothing I've tried will work. 

Probably a very noob question but I'm using PuTTY/SSH to login to my virtual machine.  When I run confconsole, the line-drawing characters appear as letters, etc.  I tried setting the Terminal type string in PuTTY to "linux" but that only changed the display from letters to a set of block like lines. 

If I run confconsole in the console on ESXi, the line-drawing chars are interpreted correctly. 

What am I missing here?  It's decades since I last had to play with this sort of thing.



EDIT: Attached image

Jeremy Davis's picture

Hi Phil

It's a known issue which is noted on our issue tracker. As I mentioned there, unfortunately there isn't a reliable way that we can fix this server side. And as I don't have a Windows PC, I haven't been able to test it to work out exactly what is required.

However, my reading suggests that there are 2 things at play. One being the character encoding - in PuTTY you need to set it to UTF-8 - as noted in this ServerFault answer. TurnKey should already default to UTF-8 so you shouldn't need to change anything in your server.

It's the other bit that I'm not so sure about. Hopefully you can help out there with a bit of trial and error?! My suspicion is that this answer (on the same ServerFauly thread) may do the trick?! I.e. setting the "terminal type string" to .

If that still doesn't work, then perhaps this answer (on a different thread; a SuperUser question) may be what's required? (FWIW, it is also mentioned in commetns on the other thread I linked to). Note, that will need to be done on your server, so something like this:

echo "export NCURSES_NO_UTF8_ACS=1" >> ~/.bashrc.d/defaults

Then log out and back in again.

You may need to make those changes before you connect (or perhaps you'll need to disconnect and reconnect?). If it still don't work there are many additional answers on that same thread which may be worth a try. Please note that that thread is explicitly referring to use of the "midnight commander" software, so any answers referring to that software are irrelevant. However, the general concepts of many answers should still apply.

Please let me know how you go so we can add a specific workaround to the issue on GitHub.

Phil B's picture

Many thanks, JD.

I'll probably have some time tomorrow to experiment with these potential solutions.

Hard to believe I didn't stumble upon those when I was searching.  Thought I'd tried everything :)

I'll definitely let you know if I find a way to make this work.



Jeremy Davis's picture

Hopefully it doesn't take too much mucking around. Hopefully you can work it out pretty easy.

Assuming that you can work it out, it'd be awesome to hear how you go as it'd be great to be able to post a specific workaround.

FWIW my google-fu skills are pretty strong! :) Often it's just a case of knowing what key words to use! 

Add new comment