Jason Cossaboon's picture

Love the product but somehow twice in the last 2 weeks, I got flagged for spamhaus

The message when checking spamhaus is


X.X.X.X appeared to be suspicious because it was using the following name to identify itself during email connections (port 25) via the HELO/EHLO smtp commands: "wordpress".


How can I change the HELO response? My firewall shows only one device doing outbound port 25 connections and it was the turnkey product.


Jeremy Davis's picture

To explicitly change the name that postfix presents via the HELO exchange, change the value of "myhostname" in postfix conf (/etc/postfix/main.cf). I.e. find the line:

myhostname = wordpress

And change the 'wordpress' to something else (ideally a FQDN that has valid DNS entries).

Then restart postfix:

systemctl restart postfix
Jason Cossaboon's picture

Thanks for the fast response. 

I am at the command line of the appliance and logged in as root, but am unable to navigate any further

ls command shows nothing.

My linux knowledge has faded over the years but I have to be missing a simple command somewhere.


Any thoughts? If I could just navigate to the directory, a quick vi editor would fix it

Jeremy Davis's picture

When you log in via SSH, you will land in your user's $HOME. By default that's /root for the root user, for other users, generally /home/$USERNAME.

To navigate, use the 'cd' (change directory) command. Some examples:

# absolute path
cd /path/you/want/to/go/to
# relative path
cd path/to/sub-dir
# up a directory level
cd ..
# up multiple directory levels
cd ../../..
# to relative path in different directory tree
cd ../../other/directory/tree
# back to last directory
cd -
# back to $HOME

Re editing with 'vi', FWIW TurnKey has 'vim-tiny' installed, with default settings somewhat matching the old default 'vi' config. So you can use either 'vi' or 'vim' or 'vim.tiny' commands and either way, you'll get vim-tiny. If you want "proper" 'vim', you can install it via apt.

Also, whilst it can something be useful to change directories, you can edit files via absolute (or relative) path. So to edit the postfix main.cf file you could do this:

vim /etc/postfix/main.cf

Hope that helps...

Also FWIW TurnKey is based on Debian. v15.x = Debian 9/Stretch. Our upcoming and overdue next major release, v16.x will be based on Debian 10/Buster. So as a general rule, info relevant to Debian is also relevant to TurnKey. So for general OS related stuff, often a google search will help you out. OTOH, TurnKey does tweak some config and does have a few extras, so please feel free to double check and/or ask here if you need. :)

Jason Cossaboon's picture


Thanks. In the end it was not me, turnkey or my lack of linux

The vmware remote console plugin was acting up.  Putty worked fine for ssh

the new version of the remote console also fixed the issue


Jeremy Davis's picture

Personally, I don't tend to run local VMs so I sometimes forget that there's any other way (than SSH)! :)

Also I hope my "Linux 101" tips didn't feel like I was talking down to you at all. It's sometimes hard to judge someone's knowledge experience level. For the sake of others that may stumble across this thread and to reduce the back-and-forth, I try to be fairly exhaustive with my responses...

Anyway, really glad to hear that you worked it out. Please don't hesitate to post back if you hit any further issues, have further questions or have suggestions and feedback for making it better.

Add new comment