Ken's picture

I install new Turnkey wordpress 16 on new lxc proxmox. After configuration i can't connect to wordpress with ip that i configed. I install the old Turnkey 15 with the same configuration as version 16 and i can connect wordpress normally. Could you help me to resolve problem with version 16. (in version 16 i can ping to ip of wordpress lxc normally but cant access via browser)

Here is my proxmox server info

root@pve:~# hostnamectl 
   Static hostname: pve
         Icon name: computer-server
           Chassis: server
  Operating System: Debian GNU/Linux 10 (buster)
            Kernel: Linux 5.3.10-1-pve
      Architecture: x86-64

Jeremy Davis's picture

Our old v15.x containers had a default Postfix configuration that wouldn't allow them to run as unprivileged (see the issue).

We made some changes so that is no longer the case in v16.0.

However, due to some changes in Buster (what v16.0 is based on) now v16.0 will only run (with default config in Proxmox) as unprivileged!

So for the new containers, it's recommended that you run them as unprivileged and everything should "just work". If you want to run privileged, then you'll need to enable "nesting" for that particular container. See more info in the issue.

Ken's picture

I enable nesting for the container and it is now working normally

Thank so much for your infor :)

Jeremy Davis's picture

Glad that worked for you! :)

Although as I say, unless you explicitly need privileged containers, you're probably best just launching unprivileged ones. They should "just work" (without needing "nesting" enabled).

Add new comment