TurnKey Linux Virtual Appliance Library

Dropbox on TKL container (file server)

pum's picture

Just tried to install dropbox on a TKL File server

Dropbox on Linux usually finds an issue and offers the solution:

Unable to monitor entire Dropbox folder hierarchy. Please run "echo 100000 | sudo tee /proc/sys/fs/inotify/max_user_watches" and restart Dropbox to correct the problem.

However, in a container /proc/sys/fs/inotify/max_user_watches cannot be changed (even by root). Probably this file isn't owned by this container (instance) and is shared by all containers.

Questions:

  • is it possible to change this status of individual files, i.e. add it to the container and not the OpenVZ framework
  • is it perhaps better to create a VM (instead of a container)? What are the performance implication when the file server is shared between multiple VMs/Containers
  • is it perhaps better to allow the host to sync dropbox and to allow all VMs & Containers access to those (and other) files? What are the performance implications here?
PumWalters's picture

Dropbox on the server works well so far

(I should mention that this is a 50 GB file tree; multiple copies on different VMs on the same server is nonsensical)

Currently I have Dropbox on the server shared with one container (as described here), which is a TKL file server that exposes the filetree to other VMs (via Samba etc). No other VM shares the Dropbox filetree directly, nor does the server directly change files (to avoid the problems mentioned by @L.Arnold). This seems to work for me (CAVEAT: I am the only user of this server and am therefore aware of potential editing conflicts on the same file from different locations, though it has happened at times :-)

Dropbox uses about 750Mb of memory and has used 8 minutes CPU time over 155 hours uptime.


Jeremy Davis's picture

Did you check Google?

It turned up quite a few results, all basically saying the same thing. That even if you do what the error messages suggests (which it seems you can't on an OVZ container) that it still doesn't actually fix it. To fix it you need to edit /etc/sysctl.conf:

nano /etc/sysctl.conf

and add the line:

fs.inotify.max_user_watches = 100000

(<Ctrl><X> - <Enter> to save and exit) then:

sysctl -p & dropbox stop & dropbox start

Apparently a reboot should demonstrate that it now all works...

Please note that I haven't tested to confirm that this works (but be great if you could).

Sources:
http://blog.koppi.me/2011/12/howto-dropbox-unable-to-monitor-issue-on-ub...
http://technologytales.com/2012/09/24/getting-rid-of-a-dropbox-error-mes...
http://www.mariusv.com/solve-the-dropbox-filesystem-monitoring-issue/

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)