Forum: 

Is HTTP/2 support included and available in all Turnkey virtual appliances?

Keyturns's picture

Is HTTP/2 support included and available in the Turnkey virtual appliances such as the Wordpress 14.1? How can I tell if it is installed and how do I enable it? If not, will it be in the upcoming 14.2 versions?

Jeremy's picture

Technically it could be (if we used Nginx instead fo Apache) but the current appliance uses Apache as it's webserver. And HTTP/2 support unfortuantely isn't avaialble for the version of Apache in Debian Jessie (the base of TurnKey). As v14.2 will still be based on Jessie, it still uses the same Apache version (with backported security updates auto installed). 

So at this point, I wouldn't anticipate OOTB support for ou appliances until v15.0 (which will be based on Debian Stretch).

Post new comment