Witzker's picture

I have installed Jellyfin on my Synology DS418 and connected a library to a Folder with MP3s called music on my Synology.

This worked, but I had to find out that my old DS418 is far too weak to handle the big library.

So I installed your Media Server OVA on my tiny Elite 800G4 in ESXi 7 as a VM.

This worked great, and I was also able to update to Version: 10.8.4 following your description here:

How To update Jellyfin in your Media Server.OVA | TurnKey GNU/Linux (turnkeylinux.org)

But This update didn't solve my problem to connect to the music folder on my Synology. I do not understand what to put here when creating a library:

pls see attached picture:

As you have also a file server in your OVA and I don’t need it / only Jellyfin with connection to music folder on Synology)

I thought that maybe this server is blocking the connection.

How can I uninstall it to only have Jellyfin working in the VM and that connection to music folder on Synology

What do you think?


Jeremy Davis's picture

I'm not familiar with Synology and google isn't really helping me.

Looking at the screenshot you've given, it looks like Jellyfin wants either a local path or an SMB style URI (often called a UNC path). I.e. something like:




Assuming that your Synology has SMB (Server Message Block aka Windows File Sharing) enabled, then you should be able to enter it's IP (or hostname - if it's set up to support that) and path to the shared folder where your MP3s reside. Note that that won't necessarily be the filesystem path on the Synology (in fact almost certainly won't be).

You could use your PC file manager app (such as Windows Explorer (Windows), FileManager (Mac) or whatever on Linux) to browse your Synology via SMB to confirm the path to your MP3s.

Another option would be to mount the Synology share from within the Jellyfin server first (e.g. via Samba client - there are likely other options such as NFS, SFTP, etc too). Then use the locally mounted file path in Jellyfin.

The specifics of how you do that will depend on what protocols your Synology supports/provides.

Add new comment