TurnKey Linux Virtual Appliance Library

Shared Folder / Guest Additions / Drupal

Bruno's picture

Hi there,

I have to confess, I am totally new to linux/Unbuntu and that might be the problem.

I am running VirtualBox 2.2.2 on XP and started your Drupal 6 appliance. Everything is doing fine, and after I found out about NAT/Bridge I can access Drupal also from outside.

A big Hug here for you guys by teh way for all that work and the good install description.

But... :) I like to install additional language packages to Drupal. Unfortunately I could not find out how to get these in the right folder. I simply have no clue how access the Drupal subdir from XP or via FTP.

As said, I am new to Unbuntu and I am not able to get the USB or Disk link to work. As far I understand I have to install „Gasterweiterung installieren..“ (Now I had my outcome as German) (it means „Install Guest Additions“). I understand that I can not use the mount command until I installed these. My chicken egg prob is now that according to the VB manual I have to have GuestAdditions installed to mount shared folder with the host but I can not access the GuestAdditions.iso without a shared folder. ??

I guess I getting something totally wrong here .. but what? :)

By the way, I am only able to use ls, mkdir and cd in Unbuntu :) (and a bit nano).

And yes, I tried to simply click in the Guest menu „Install Guest Additions“.

I also tried to use Device > Mount CDRom > Mount Image and selectet the GuestAddition.iso but where is this inside Unbuntu. I can not find it in /cdrom or /media/cdrom ?

If anybody has a hint or link to that problem would be really appreciated.

Aloha

szczym's picture

Maybe just sumba?

helo Bruno

Forget about guest additions and make it normally like every linux/windows installation :) via samba - its emulation of windows network share protocol.

apt-get install samba

and than add something like that to end of /etc/samba/smb.conf

[input]
comment = here split
path = /var/www/tutturu/sites/default/files/input
public = yes
writable = yes
Create mask = 0777
directory mask = 0777
force user = nobody
force group = nogroup


1. change path to your needs.
2. make command: chmod 777 -R /your/desired/path/
3 make command /etc/init.d/samba restart
when you go into your network neighborhood in winxp, you should see a drupal6 machine and inside of it dir input where you should be able to read and write.

BUT: that solution is exposing to any one your files, do it at home but not in a wild (eg. public hotspot). if you need more security, learn here: https://help.ubuntu.com/8.04/serverguide/C/windows-networking.html aloha!
Guest's picture

 Yeah I have the same problem

 Yeah I have the same problem with turnkey linux. Installing guest additions does not seem to mount the iso unless I am missing something obvious (which is quite possible).

Scott's picture

Ditto.... had the same missing cd problem

I just figured out the issue - at least in the LAMP appliance.  The cdrom is not mounted into the file system.  The cd is "in the drive" - but the drive is not actually mounted.  In the command line,  you will need to enter: mount /dev/cdrom /cdrom

 This will put the cdrom into the filesystem so you can then go through the installation.  However, it seems I have into insall a zip utility to do the install.  If it's not one thing, it's two!

Hope that helps.

SC

 

Scott's picture

Re: automount?

In the LAMP appliance, there is no desktop.  There is no graphical interface at all - it's all command line stuff.  I assume that automount is either associated with the GUI or is a feature stripped out of the Turnkey Ubuntu version.  Could be wrong, but I know the cdrom iso worked after mounting it via command line.

Cheers,

SC

Guest's picture

mount point /cdrom does not exist

I get "mount point /cdrom does not exist" when running the mount command

Jeremy Davis's picture

Did you create the mount point first?

Ie does the folder /cdrom exist? If not make it like this:

mkdir /cdrom

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)