Senilebob's picture

I have setup a LAMP appliance, and forwarded port 80 from my router to my LAMP server's static IP address.
I also have DynDNS setup, and working fine.

But no one can remotely access my server via default port 80.

I had a look through the firewall settings, and port 80 TCP traffic is allowed, but still cannot get it to load.

I have another server (proprietary hardware automation system) that also has a web server built in, running on port 81, and have that working fine remotely using DynDNS and the same port forwarding settings page.

The router itself is set to use port 8080 for remote administration, so that should be fine.

Is there some setting I need to change to allow remote access?


Senilebob's picture

 I also tried changing the port from 80 to 8000 incase port 80 was being blocked by my ISP, and still same problem. Local access is fine (even using the DynDNS url, my router supports NAT Loopback), but remote access (testing from various people, including using my iPhone over 3G) is still not working.

Any help is much appreciated.

Jeremy Davis's picture

I could only assume a firewall/port forward isssue or similar. Try using something like GRC SheildsUp ( or another remote port scanner to ensure the port is open/unblocked/forwarded correctly.

Perhaps try to access your server through an online proxy using your DynDNS domain name to ensure its working ok (or not as the case may be).

Also traceroute may be able to assist you with where the connection is falling down.

Senilebob's picture

 I used ShieldsUp, and the port is reporting as 'stealth'. I then tested another forwarded port to a different web server and it was open. So I simply changed the IP address to point to the LAMP appliance, and it reported as stealth again - same port that was open. Only difference is its being forwarded to the LAMP server now instead of the other web server.

Yes, the IP address is correct and I have the Apache server listening on the correct port (tried 80, 8080, 8000, 8009) none of which worked. Using port 8009 on my other web server, and there is a third device with a web server on port 81, and they both work perfectly fine. It's only the LAMP server that is not accessible remotely.

I am running the appliance on Virtualbox on macosx 10.5.8. Virtualbox networking is set in bridged adapter mode. Just incase there was some issue with a firewall running on my mac, I checked and its set to allow all incoming connections, and Little Snitch is turned off whilst Im testing all this.

It is ONLY the LAMP server that is not remote accessible, surely that means theres something wrong with my LAMP config somewhere?

Appreciate the help, thanks.

Senilebob's picture

 Hmm... So I changed the network adapter to PCNet in virtualbox settings (was using intel adapter) and its now working... strange!

Jeremy Davis's picture

It does sound strange, but glad you got it worked out.

brucew98's picture

Hi. I am having the same problem you had, but the solution for you definitely didn't work for me.  I even turned off my firewall and asked various people to try to connect and they could not.

Please help.

Jeremy Davis's picture

Your post slipped through the cracks over the holiday period. Partially I think this was because you didn't start a new thread (not that you should have to but I often quickly check the forums for posts with zero replies). Anyway...

So what have you tried? What have you tested (eg can you access your LAMP from other PCs on your LAN? Have you got port forwarding correctly set up? Do you have a static external IP or some sort of dynamic DNS updater configured and running? Have you checked that port 80 (and/or 443) is open and available on your domain/IP? (You can use an online port scanner to check this - eg ShieldUp).

Give me some more info and I'm more than happy to try to help you troubleshoot.

brucew98's picture

Hi Jeremy. I think I've tried everything with the exception of opening up ports 80 and 443 since I am port forarding another port. I am als using dyndns. I can't see what I'm doing wrong.

Jeremy Davis's picture

When you say you are forwarding an alternate port, are you still forwarding it to 80/443 internally? Have you tested that the alternate port is open from the outside (using a port scanner such as SheildsUp)?

Can you access your server ok from within your LAN?

Add new comment