anthony portillo's picture

Good Day EveryOne,

I cant see my website out my lan, i have my domain with CNAME to my public IP (with dyndns), the port 80 and 8080 its enable in router of my lan and iptables in 'turnkey joomla'.

In my lan i can see it very good, but i need an orientation and help for resolv this.

May you help me?

Thank for any help that you can offer me...


PD: Sorry for my bad english


Best Wishes!!!!

Jeremy Davis's picture

Set TKL appliance to have a static IP and make sure you have Port Forwarding set up on your router and pointing to the TKL appliance. There are many variations of how to do this so I can't give you instructions but has pretty comprehensive instructions for many models of router.

Another thing to check is whether your ISP is blocking port 80 and or 8080. To check that try doing an IP scan using Shields Up or similar. If these ports are being blocked then you will need to find a port that isn't and use that. You may be able to port forward to the standard port on your TKL appliance using your router but some don't allow this. If your router doesn't support it then you'll need to change the port on your TKL appliance. To access your appliance with a non standard port append :99 (where 99  is the port number) on the end of the address eg


godfearer401's picture

I need to change the default port that many of my TurnKey Appliances are sending out web pages from port 80 to something else.  Given it is so easy to change the static ip address while running these appliances via virtualbox, I figured it would be just as easy to change the default web port.  But, so far I haven't had much success.  I see JedMeister's comment saying...


"If your router doesn't support it then you'll need to change the port on your TKL appliance."


Is there an easy way to change the ports on the appliances?  Is this method of changing the same for all the appliances?  I assume there is a config file that needs modified.  Which file is it?

Jeremy Davis's picture

but I'm not sure. OTOH editing the conf file is pretty easy. These instructions should work (they are based on standard Apache2 setup but are untested on TKL).

The file you need to edit is /etc/apache2/ports.conf file. So in a terminal type:

nano /etc/apache2/ports.conf

(please substitute your favourite text editor if desired) and look for this line:

Listen 80

and change the 80 to whichever port you want. Then restart apache:

/etc/init.d/apache2 restart


godfearer401's picture

Thank you for responding to my question.  I made one attempt to change the port from 80 to 209.  The response now from just trying to get into the appliance's web page on default port 80 is "unable to connect".  When I use the ip address:209, the response is "the requested url was not found on the server".  This tells me that apache is listening correctly on port 209, but something else may need changed....or, maybe I didn't do it precisely like you instructed.  I intend to go back and try it again in order to make sure, but thought giving you this information might trigger your thoughts that I need to change something else as well.  


One other side note.  While running from virtualbox, the appliance shows the configuration console ip addresses and ports for various services (Web, Web Shell, Webmin, SSH).  It is not important that the port number show up (ie 209) on the Web service, but you may have expected it to change.  It still doesn't show any specific port for the web service.  Just thought that piece of info might be useful when considering this issue.

Jeremy Davis's picture

I'm pretty sure those instructions should work and a quick google didn't turn up anything obvious that I've missed. Restarting apache should be all it needs for the new config to stick, and by the sounds its doing something, just not what we want!

I'm assuming that initially you could access the content locally no worries, just not remotely? What about since changing the port? Can you still access it locally? I'd guess not. If you can access it locally via the new port but not remotely then there is something in your network interfering.

Also if you are using virtualisation it may be best to start with a fresh VM, tweak it and get it working on an alternative port then adjust all the others. That way you eliminate any issues about risking your content or already (almost) functioning appliances.

And just to confuse the issue - Have you got your TKLs running on baremetal or in a Virtual Environment (VirtualBox/VMware etc)? If using virtualisation, most platforms have some sort of NAT/port forwarding built in, which may be another way to skin this cat.

godfearer401's picture

I performed the modifications you suggested on another Turnkey (virtualbox) installation and it worked. 

However, I also made a change insdie the webmin application which is part of the Turnkey installation (ie...opening up port 12321 in the browser).  The webmin toolbar has the toolbar with one of the options being Servers.  So I dropped down the Server option and selected Apache Webserver.  On the resulting page, there is a listing of Default and Virtual Servers.  The first Virtual Server I found was still set to "any address" and "Port 80".  I also made the change on the ports on this virtual server to "Port 209" as well.  I did this in conjunction with following the instructions offered by JedMeister.  

I only tried only doing JedMeister's suggestion on the first attempt which did not work, but then I did both JedMeister's and my webmin change on the second attempt and it worked. 

I am still thinking that just performing JedMeister's suggestion only would work...I think I must have done something wrong.  The only thing I am a little confused about is why the Virtual Servers didn't change the port they were reporting to be connected to.

Thanks JedMeister for getting me through this.

Jeremy Davis's picture

Sounds like it all worked out with Webmin. Not sure why it worked ok that way but not the 'manual' way. I thought Webmin basically just did the same thing behind the scenes, but perhaps not and there was something I left out?

Anyway all's well that ends well

Add new comment