Forum: 

unable to load samba using sudo command

Alan Douglas's picture

I'm a linux newbie, so the Turnkey build for Joomla was the quickest way to load up Joomla. Many thanks for this.

Now I see that I need Samba so I can copy content to the Ubuntu machine from my windows PC.

the following command fails:

sudo apt-get install samba

also the following command seems to suggest that sudo has been removed?

bash: sudu: command not found ??

Any ideas please?

Jeremy Davis's picture

SFTP is enabled by default and is much easier to get going, more secure and in my experience much more reliable. This comment I posted last week contains some relevant links. You connect using the IP address given on the TKL Config Console screen.

If you wish to push ahead with Samba (or you want to install anything else) you do not need to prefix the sudo command. By default you log into TKL appliances as root (admin user) and as such the sudo command (which gives admin rights to normal users) is not required or as you guessed even included.

Post new comment