Scott Howard's picture

Hi Guys, as stated befere here I'm running the lucid samba file server appliance. Each night I do standard Amazon remote back up , and a local backup onto another windows machine for safety ??

I am in the testing the restore phase now , so I started with the local back up because it would be faster. I installed a fresh baremetal install of the appliance on the same machiine in an identical way to the original.

To begin the restore I , exited the confconsole and logged into a shell as root on the machine, and initialised TKLBAM-INIt etc , all well

I also created a passphrase for the local backup as requested.

I also installed smbfs and swat as the local backup copy is on a windows XP machine.

All well , can mount / and access the appropriate directory etc.

However , when I run tklbam-restore  --address<..................> --keyfile=<................>

I get all sorts of duplicity errors complaing about no backup chains etc.

BUTT !!!!!

If I login in to the fileserver appliance via web shell and run the identical command it all happens flawlessly and restores the machine to its previoius fully working state with full data integrity.

Is this the way its meant to be ?? I cant think that it would be.

I havent tried the same thing with the remote amazon backup yet due to time constraints.

 Appreciate any comments or input.

Thanks again.

Scott H.

Jeremy Davis's picture

I haven't used Shell-in-a-box (SIAB - I assume that's the web shell you refer to?) much but I would imagine that you should receive the same response regardless of whether you access the TKL appliance via local console, SSH or SIAB. Are you 100% sure you are logging into the same machine as the root user in both instances?

I can't help you with your error, but it'd proably be useful to post the exact error message as then Liraz (the authour of TKLBAM) or someone else may be able to gain some insight into what is going on.

Scott Howard's picture

Its quite odd isnt it ?

Yes I'm sure I'm logging in as root on the local console and  with webshell.

I'm running the exact samce command each time , and I ve replicated the whole thing twice to ensure I wasnt going nuts ....

I think I redirected the output last time into a file, so I can post this , but If I havent I'll do it again and post this.

It sort of reminds me about the PATH environment issues I had with the fixclock hook.... wondering whether the local shell and the remote shell have different PATH environments set.... 

Jeremy Davis's picture

But I still consider myself a bit of a Linux newb so probably know a lot less than you!

If/when you have a file of the error message you can attach it to your first post (only initial posts can have attachments) and bump the thread with a new post.

Scott Howard's picture


Here is the output  when attempting to do tklbam-restore  --address<...............> --keyfile=<..............>

from the local root shell. As pointed out in previous post of 30/11/2010 , it works if done from remote webshell !

Output :

Restoring duplicity archive from file://mnt/Backups/TurnkeyBackups/
Local and Remote metadata are synchronized, no sync needed.
Last full backup date: none
Traceback (most recent call last):
  File "/usr/lib/tklbam/deps/bin/duplicity", line 1252, in <module>
  File "/usr/lib/tklbam/deps/bin/duplicity", line 1245, in with_tempdir
  File "/usr/lib/tklbam/deps/bin/duplicity", line 1199, in main
  File "/usr/lib/tklbam/deps/bin/duplicity", line 539, in restore
  File "/usr/lib/tklbam/deps/bin/duplicity", line 561, in restore_get_patched_rop_iter
    backup_chain = col_stats.get_backup_chain_at_time(time)
  File "/usr/lib/tklbam/deps/lib/python2.6/site-packages/duplicity/", line 934, in get_backup_chain_at_time
    raise CollectionsError("No backup chains found")
CollectionsError: No backup chains found

As I said, I'm not sure why there would be any intentional reason to not allow the use of the local machine shell for this purpose .... Liraz  are you out there ???

Liraz Siri's picture

The difference lies in the current working directory under both environments. If you had done a "cd /" before the restore command it would have worked the same.


file://mnt/Backups/TurnkeyBackups/ is a relative path: mnt/Backups/TurnKeyBackups. Because file:// is the protocol part of the URL. Get it?

If you want an absolute path you need an extra slash after the file:// as in file:///mnt/Backups/TurnkeyBackups/

"No backup chains" just means it couldn't find a backup at the address you provided. Not the most intuitive error message but that's Duplicity for you. Now maybe you see what I mean about those tiny paper cuts we tried to avoid by automating everything when you use the default Amazon S3 storage backend.

PS: Sorry for the late response but I was offline for most of last week. BTW there's no need to double post a message, we get to everything eventually.

Scott Howard's picture

Thanks again for your response, sorry to waste your time with fundamental errors... I hope my next question has more merit to it.

Jeremy Davis's picture

I learned something so it's all good! :)

Add new comment