Forum: 

How to change phpmyadmin port without crashing everything

Hi, new guy here!

I was able to change ports for everything on LAMP, except phpmyadmin.

I have a bit of a firewall policy problem here, so I have to stick with predefined university ports. Webmin on 989, apache on 80, and phpmyadmin on 9090.

Everything works fine, but I got stuck with phpmyadmin. netstat tells me that it's listening on 9090, and sometimes I can even get a TIME_WAIT to show up. But have never been able to connect again after changing from 12322 to 9090.

Any help would be nice!! Thanks!

Landis Arnold's picture

Well, realistically, make a backup first.

Then, go to Webmin-Apache Server and change the port setting for PHPMYADMIN to 9090.  See if it works.

I think the Webmin and SSH settings are set elsewhere but likely the same process

I have been able to change Folder settings this way.  I can't say I have been successful controlling PHPMyADMIN.  One time though it just ended up after install in its own folder under port 80.

apt-get install ... some variation of phpmyadmin on a Core Install.

Jeremy Davis's picture

If you have a look at Basil's LAMP patch that may help you sort it out. Basil initially had some issues but sorted it all out. I'm 99% sure that he used Apache. Have a look at the Apache configs in /overlay/etc.

Post new comment