Keith Shering's picture

Hi all, I'm a Linux newbie, so apologies in advance if this is (or should be!) obvious - but thought I'd share this to help other newbies! :D

I set up a Wordpress appliance (11RC version) - all worked lovely on a VirtualBox VM. Very impressed!

I then installed the same appliance on a physical PC (a FoxConn Netbox 410 - mini PC, Atom D410, 1GB RAM - that sort of thing). 

I started to see a few "funnies". For example:

  • The CSS for the default theme appeared to not work correctly - wrong fonts, misplaced page elements, etc.
  • Deleting and downloading things would temporarily fix this - sometimes...
  • Images (JPEGs and PNGs) were often either absent, or "got more corrupt" from top to bottom.

I could sometimes fix this temporarily by restoring the affected files from a backup - but even when this worked, rebooting the PC would bring the problems back.

BTW, I could repeat the problem with a LAMP appliance, taking Wordpress out of the picture.

What perplexed me is that the same build on the VM was fine after reboots! On the PC, I also checked a load of physical things like disk surface errors and the like to take hardware faults out of the equation.

Anyway... I did a stack of Googling (with a smattering of Binging for variety) and discovered this link:

It described the symptoms I saw, and suggested that sendfiles in some kernels doesn't quite work correctly.

I added the line "enablesendfile off" to my Apache config.

This has appeared to solve the problem for my Wordpress appliance on the physical PC. Looks like the size of the image files, and larger CSS files, was bringing the kernel sendfile into play.

As I say, this might just save a beginner like me a day or two of troubleshooting (or 5 minutes for an expert ;)


Jeremy Davis's picture

This will surely help someone else who has the same issue. Nice work. :)

Add new comment