Don Sanderson's picture

After restoring a small backup to a new instance of the DokuWiki appliance (both v11.1) that I installed on bare metal I encountered the following:

1.) The "docuwiki appliance services" firstboot screen appears after every reboot.

This has to be exited before services will run.

How do I prevent this from occuring?


2.) Webmin will no longer start as the configuration expects to find it in /usr/share/webmin-1.530/, it is in reality in /usr/share/webmin/.

I created a link in /usr/share/ "ln -s webmin webmin-1.530" and now webmin runs OK.


When first booted the install asked me to do updates and I said yes, could this be what trashed webmin? I don't remember if the machine the backup was made from had been updated yet.

All other functions seem to be OK and changes/files correspond to the instance it was backed up from.

Don Sanderson's picture

After install the appliance logs in automattically as root.

I have to admit I'm used to RHEL/Cent/Fedora where security is overdone if anything, but this seems a bit scary.

Don Sanderson's picture

OK, I tried this again with 2 bare metal installs and things went much better.

The First time around the machine I backed up was running in a qemu VM from the LiveCD iso.

Aparently that isn't a good idea.

This time both were bare metal and things went better.

Still had some issues with changes to the wiki being properly displayed, I'm still working on that one.

The WebMin and root login issues are solved though.

Jeremy Davis's picture

I think you must have posted while I was writing :).

Anyway sounds like you've got many of your issues fixed. As for running as a VM, it shouldn't make any difference whether you are using bare metal, Amazon or any range of VM options. TKLBAM should be completely underlaying platform agnostic. It could be interesting to discover what was causing your problems though as it shouldn't have been like that.

Also it may be useful to document what changes were required to make your wiki display properly, perhaps there are some tweaks and adjustments that need to be made to the TKLBAM profile for this appliance to function  properly after a TKLBAM migration/restore? Alternatively perhaps you are putting things in 'naughty' places?

Jeremy Davis's picture

But your first issue shouldn't be an issue. I may be wrong but I think you are referring to the Config Console when you speak about "docuwiki appliance services". Is this what you are referring to?:


If I'm correct this is by design and it is just coincidental that it seems like the services don't start until you exit. It is probably more likely that the services just take a few moments to initialise.

As to your third point, it should not auto login at all. To get to the root CLI you should have to exit the ConfConsole and log in using your password.

Don Sanderson's picture

and document what I do, but so far:

1.) Yes, it was the Config Console, only mine says "DOKUWIKI appliance services" where yours says "Usage". It no longer seems to be an issue.

2.) The root autologon seems to carry over to the backup when made from a liveCD. I will explore this further. This worked fine when the backup was made from a running installation.

3.) Edits to DokuWiki were made thru DokuWiki itself. They showed up as "unsaved edits" after the restore. 'Naughty locations' were carefully avoided.

4.) My 'gut feeling' is that the system should be rebooted after initial configuration, and before an initial full backup is made, to restart services, reload config files, and 'clear the baffles' so to speak. This is impossible when using a liveCD and may be causing issues. PLUS, the initial round of security updates installs a new kernel, again a reboot is required to boot to the new kernel, not possible on a liveCD instance.

I'll play with this more and report my findings.

Add new comment