Forum: 

Can't install jQuery_UI module in Drupal 6 appliance

Monte Milanuk's picture

Hello all,

I've got a nice clean Drupal 6 appliance running in Vbox 4 on my Macbook... having a bit of trouble installing the jQuery_UI module.  When I try to install it, I get the following message in an error box at the top of the Module page:

 

  • The Date Popup module now requires the jQuery UI module as a source for the datepicker. Please install it immediately.
  • The jQuery UI plugin is missing. Download and extract it to your jquery_ui module directory. (Currently using jQuery UI Not found)
  • The Date Popup module now requires the jQuery UI module as a source for the datepicker. Please install it immediately.

Any suggestions?  The directions in the README.txt file under /var/www/webroot/sites/all/modules/jquery_ui/ says to download 1.6 (newer than what came with the appliance and install it under this directory, and makes reference to a subdir 'ui' containing *.js files.  Not finding any such directory or files, either in the existing directory nor when I download the tarball for 1.6 and extract it as described (looks pretty much exactly like the directory already there...?)

TIA,

Monte

Monte Milanuk's picture

Think I figured it out... I started over with a basic LAMP appliance and installed Drupal from scratch (for other reasons) and came up against the jquery issue again.  After reading things a little closer, I realized while there already was a jquery_ui module, the README.txt was asking me to download the jquery.ui-x.x.zip file, which is something entirely separate.  Still not sure why that isn't included by default in a 'Turnkey' appliance, though.  Is it a licensing issue?

bipin's picture

same prblm here i also try to intall in libraries directory of sites but error id still coming...what to do..?

Post new comment