Hello -

I've installed the acl package on some of the appliances, and the icon appears in the webmin file manager (next to EXT), and whenever I select a file/folder, pressing the EXT or ACL icon gives the error:

"The filesystem / does not support ACLs" or "The filesystem / does not support EXT attributes".

Any advice?  I'd like to use this through webmin.

Replies (5)

ACL, EXT in turnkey PDC

Reply 1
I, too, am having difficulty with this. No matter what filesystem I format my drives with, they do not seem to support ACL or EXT attributes. I'm working from within a Windows environment and need the granular control of ACLs. Has anybody come up with a fix or a workaround?

Changes to fstab

Reply 2

Assuming you are using ext3 or ext4 filesystems they are capable of supporting ACL and EXT.

These must be enabled in the /etc/fstab file.

Line one below shows a 'stock' fstab line as TKL set it up for my hard drive / partition.

The second line shows it edited with acl and user_xattr options enabled.

UUID=3ff4fd5b-e7f8-496c-8f51-7111642cb0f2 /   ext4    errors=remount-ro 0   1
UUID=3ff4fd5b-e7f8-496c-8f51-7111642cb0f2 /   ext4    acl,user_xattr,errors=remount-ro 0   1

You must reboot, or issue a mount -a command, to enable these options. I suggest the reboot.

CAUTION: Have a boot disk/CD handy in case you make an error, an error in /etc/fstab will cause your machine to not be able to mount your hard drive at all!!

AN ALTERNATE way to do this is to issue the command:

tune2fs -o user_xattr,acl /dev/fs_device

Where fs_device is the partition you wish to add these features to as default boot options.

This eliminates having to mess with /etc/fstab.

You can verify these setting with:

tune2fs -l /dev/fs_device

Look for:

Default mount options:    user_xattr acl

The Webmin module

Reply 3

After downloading the Webmin ACL module from here:

http://downloads.sourceforge.net/project/webmin-fsacls/webmin-fsacls/web...

And installing it the EXT and ACL entries appeared in Webmin File Manager but I had the same problem as above. However a new entry (File ACLs) under the 'System' menu in Webmin seems to work OK.

This is an EXT4 file system which may be an issue with Webmin, I am checking on that.

Workaround and Update

Reply 4
This is fantastic! I'm somewhat new to the inner workings of Linux and am replacing a failing Windows 2003 Server for login and file server. Your information has gotten me past many hours of frustration. I'm setting up a virtual domain now to test everything out. Thanks.