Can't log in to Vtiger

I created a vtiger appliance but I can't log in. Is there a default UN & PW.

Jeremy Davis's picture

But assuming you are using a VM or installing from ISO, then you should be able to set the password on first boot. I'm only guessing but I'd try admin as the default admin username  (although if you read the first boot screen where it's set it should say - it does for the Fileserver and other appliances I've tried).

syed azeem akbar's picture

Hey jeremy i just finesh creating a new account @ amazon ec2, after which i choose vtiger from u ppl, however it didn't how me the setup process.. which i could do in rackspace.. how can i create a new user name/password

http://ec2-122-248-212-71.ap-southeast-1.compute.amazonaws.com

Jeremy Davis's picture

If you use the TKL Hub then it should be really straight forward. When you launch a new server you can select your password(s) prior to starting your appliance.

I still can't log in. Now I'm running it on Amazon EC2. Does anyone know the default credentials. 

Jeremy Davis's picture

I have no idea how you can do it via Amazon. Via the TKL Hub you can preseed passwords prior to launch. It's really easy. The Hub is now out of private beta so just go sign up and see how easy it is. It's also free.

Liraz Siri's picture

Thanks for reporting this issue, I just confirmed this myself. The script that sets the vTiger password doesn't work for some reason any more. Maybe a package update broke it. We'll report back as soon as we fix it.
Jeremy Davis's picture

Lucky you came along and double checked Liraz. I shouldn't have been so fast and should've actually checked (as you did).

That'll teach me :)

Liraz Siri's picture

I checked but I accidentally put in the admin email instead of the 'admin' username. Then I talked about it with Alon and he tried it and everything worked, and the mistake was discovered.

That'll teach me :)

Liraz Siri's picture

As it turns out, the script is not broken and all is well except that the appliance page didn't document that the admin username for vTiger was admin. Simple enough, but it tripped me up too. I too tried logging in with the admin email. Anyhow, I just updated the documentation page.

I see the documentation. But it still dosen't work for me. I tried username admin, with a blank password. I also tried UN admin PW admin. Still no access. I guess you guys think I'm crazy. But it's really not working.

Alon Swartz's picture

I have a feeling that there is a misunderstanding somewhere - and no, we don't think you're crazy!

VTiger admin interface:

Jeremy and Liraz are referring to the VTiger administrative credentials used to log into the VTiger interface, located at: https://your-ipaddress

The username for VTiger is admin and the password is what you specified when launching the appliance via the hub in the VTiger admin password field.

Just to be clear, there is no default password (i.e. blank, admin).

Webmin, WebShell, SSH, PhpMyAdmin, etc...:

There has been confusion in the past, so just in case: When connecting to webmin (https://your-ipaddress:12321), Webshell (https://your-ipaddress:12320) or via SSH, the username is root and the password is what you set when launching the appliance (root password field).

root is a system account, not related to VTiger application.

Same goes for PhpMyAdmin as you use the MySQL root password (don't confuse this root account with the root account mentioned above, they're different).


I hope this clears some things up - if not, then excuse my overly detailed response.

I reinstalled it on my VMware ESXi box and it worked with the admin username. Thanks for all the help guys. 

But for some odd reason if I launch an instance on Amazon EC2 that username (admin) won't work. I guess it's because it's not as detailed as installing it yourself. With Amazon there's no first boot like when you launch it on your own personal cloud. 

With Amazon you put in all the credentials and press launch and away it go. The first log in is Vtiger, but when you try logging in with the admin credentials it dosen't work. 

So again thanks for all the help. Vtiger is working!

Lenny's picture

worked yesterday, no changes made but here is the error: 

{"success":false,"error":{"code":"Illegal request","message":"Illegal request"}}
Jeremy Davis's picture

I am unfamiliar with vTiger and have no idea why it would do that. My guesses are that either it uses some extrenal resource (likea javascript file or something) and it can't find it currently; or perhaps a security update has broken something (I would suggest that this is unlikely but not impossible).

Do you have a recent backup? Assuming that you do, perhaps restore to a new server (VM or cloud) and see if that too has the issue or if it works...

Al Ramos's picture

I also deployed an instance in AWS and in my local VM server and both are acting the, i get the "illegal request" if I try using HTTPS, if I do only HTTP it works great.

 

Any more ideas?

Jeremy Davis's picture

I have just launched a v14.1 vTiger appliance on AWS (via the Hub) and will see if I can reproduce the issue.
Al Ramos's picture

I notice that if I use the url from AWS, it works fine. ec2-35-167-168-242.us-west-2.compute.amazonaws.com. But I created a more friendly name to re-direct to the real URL and that is when it doesn't work. (https://tfl-crm.ddns.net)

Jeremy Davis's picture

And even accessing your server via the FQDN (https://tfl-crm.ddns.net) works fine for me!? Obviously I don't know your password (and I don't want it) so I can't actually log in...

FWIW I am using Google Chrome Version 55.0.2883.87 (64-bit) on Debian Linux. Perhaps try an alternate browser? Or maybe you have sort of adblocker/tracking blocker that is mangling your traffic? You can test that by trying with an "incognito/private" window (generally plugins/extensions are disabled when you do that).

Another possibility is just stale cache/cookies. Try cleaning them and see if that helps. An "incognito/private" session should also work around that.

Good luck.

Post new comment