politicus's picture



I wanted to be able to use the shared folder feature so I tried to install the guest additions.

I just do not understand how I can install the guest additions after installing the Ruby On Rails Turnkey appliance

The only thing I could do was to install dkms. (I used Alfonso Romero's Virtualbox Beginner Guide).

The only thing I have is a command line so I can't see Virtualbox mouting the guest additions's  ISO file like I did when installed the guest additions on Ubuntu.

Thanks in advance for your help.


Additional information

- Level : Newbie

- OS : Vista

- Has allready Ubuntu installed in a separate VM.

Jeremy Davis's picture

From a quick Google it seems that you need to install a few pre-requisites:

apt-get update
apt-get install dkms build-essential linux-headers-generic

IIRC TKL doesn't automount cds so you'll need to do that manually, once the CD is mounted then it should be very straightforward. Obviously the VBTools ISO needs to be mounted as a virtual CD from the VBox GUI.

Then in your appliance terminal you can double check whether a CD is already mounted with the mount command:

mount|grep cd

If this returns nothing then find your CD drive

ls /dev|grep cd

this should give at least one result (possibly more). You may need to go through them all to find the right one, but generally it'll be cdrom or cdrom0 or similar. Assuming we're trying cdrom0

mkdir /mnt/cdrom0
mount -t iso9660 -r /dev/cdrom0 /mnt/cdrom0

Now have a look and see what is in there

ls /mnt/cdrom0

If you've got it right then it should list the files on the ISO, one of which should be VBoxLinuxAdditions-x86.run or similar. (If you haven't then repeat steps above with cdrom1, etc). Run the installer like so (note Linux is case sensitive; also adjust the path in the first line as required):

cd /mnt/cdrom0

Assuming all goes well reboot and check that it works. Hope that does it for you!

politicus's picture


Thank you so much fort this detailed answer.

I will try this asap and will keep you informed.

Thanks again.

politicus's picture


I made until I got "Could not find the X.org or XFree86 Window System".

I ran VBoxControl --help and VBoxService --help.

(I am not sure I understand the outputs...).

I have the exat outputs as here :


Could you help me understand what it does mean ?

Especially "The error is noted in my Howto: Install Linux Guest Additions + Xorg config. It's a simple if [ X ] ; then install X modules; else echo FAIL situation. It will just continue with the rest."


Jeremy Davis's picture

As you may have already worked out Xorg is the underlaying graphics management software for Linux (and other OS) desktop GUIs. It is not needed (or desired) on a server. Apparently the old version of VBox addons automatically detected if Xorg was installed and if not didn't install the mouse and graphics drivers. It looks like the new installer does too, but gives an error message when it can't find an x-server.

So it looks like it should be installed ok. The VBoxControl --help and VBoxService --help commands are to check it's all running. You wil need to restart before it will be running. So bottom line is that I think you've done it! Just reboot (if you haven't already) and providing you get the same (or similar) output as in that thread then you should be all systems go.

The only thing I'm not sure about is how you will get the feature working with a Linux server (such as TKL).

politicus's picture

Thanks. Good to know "we" made it smiley

After having restarted VirtualBox several times, I still can't use Host+L

(Feature is disabled, can't click on it).

But when trying to use the shared folder feature I don't have anymore a message telling me the guest additions are not installed. 

Seems contradictory to me. (Installing guest additions should allow me to use these two features).

What do you think ?

Jeremy Davis's picture

Most of my VMs run on a PVE hypervisor server but I do use VBox sometimes on my desktop but I just use the same remote management tools (SSH & SFTP) as I usually use for my PVE server VMs. If you are using Windows then PuTTY is a good SSH client and I find Filezilla is a good SFTP client. Notepad++ is a must for editing Linux config files on Windows and Filezilla will automatically (prompt to) reupload edited files. So bottom line is I can't really help you any more with that stuff sorry.

politicus's picture

Thanks again for your help.

Jeremy Davis's picture

Have a look here.

[edit] Just realised that you posted on that thread already. If you had problems perhaps either post on that thread  detailing whats hapening (or not), especially any error messages etc.

Add new comment