I have  simple question: do turnkey linux servers come with wifi support?

I've installed the file server iso on a laptop (not as a VM) and wired networking works fine. When I want to use the wifi it can't find anything (meaning, in the admin utility the ntworking section finds eth0 and eth1, but neither can find a network or get an ip). I could not find the iwconfig tool either.

So - can I use a wireless network card in a turnkey fresh installation? If so, which tools do I have to set it up (select a network, set encription protocol and password?)



Alon Swartz's picture

You'll need to install the following packages to get wireless support. You can configure everything on the cli, including connecting to encrypted networks. I have crib notes lying around somewhere, so if googling doesn't help, let me know and I'll try find them.

apt-get update
apt-get install wireless-tools wpasupplicant

OK, sounds simple, but...

First I made sure I am connected to the internet (wired) with a simple ping to google.

Then I issued the apt-get update command. I get a [waiting for headers] reply with 0% for a very very long time. I guess apt-get can't find the repositories?

How can I overcome this?



Alon Swartz's picture

If so, you need to tell apt about it. It's quite simple to do, take a look here

No, I am not behind a proxy.

Here is the full output when I try to do it from the web-admin interface:

Installing package(s) with command apt-get -y --force-yes -f install wireless-tools ..
Reading package lists...
Building dependency tree...
Reading state information...
The following extra packages will be installed:
The following NEW packages will be installed:
  libiw30 wireless-tools
0 upgraded, 2 newly installed, 0 to remove and 44 not upgraded.
Need to get 175kB of archives.
After this operation, 541kB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  libiw30 wireless-tools
Err http://il.archive.ubuntu.com/ubuntu/ lucid/main libiw30 30~pre9-3ubuntu4
  Connection failed
Err http://il.archive.ubuntu.com/ubuntu/ lucid/main wireless-tools 30~pre9-3ubuntu4
  Connection failed
Failed to fetch http://il.archive.ubuntu.com/ubuntu/pool/main/w/wireless-tools/libiw30_30~pre9-3ubuntu4_i386.deb  Connection failed
Failed to fetch http://il.archive.ubuntu.com/ubuntu/pool/main/w/wireless-tools/wireless-tools_30~pre9-3ubuntu4_i386.deb  Connection failed
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
.. install failed!


I tried pinging the server il.archive.ubuntu.com and could not get to it.

Any ideas?

Jeremy Davis's picture

So my guess would be some sort of networking issue. The fact that you can ping google suggests that you are at least getting some network connectivity. In my experience ISP's default DNS service can be a bit flakey, so the first thing I'd do to eliminate that as a possible issue would be to set your nameserver to (Google's own DNS) which I have never had problems with. The easiest way is to set it in the TKL Conf Console.

Also, even though it shouldn't be an issue, personally I'd do it from the commandline rather than Webmin.

I changed the nameserver and verified it:

root@fileserver ~# cat /etc/resolv.conf  
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)


Then made sure I can ping something else in Israel:

root@fileserver ~# ping www.google.co.il 
PING www.l.google.com ( 56(84) bytes of data.
64 bytes from fx-in-f105.1e100.net ( icmp_seq=1 ttl=52 time=93.7 ms
64 bytes from fx-in-f105.1e100.net ( icmp_seq=2 ttl=52 time=87.8 ms
64 bytes from fx-in-f105.1e100.net ( icmp_seq=3 ttl=52 time=88.9 ms
--- www.l.google.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2003ms
rtt min/avg/max/mdev = 87.831/90.160/93.701/2.568 ms


Then I tried pinging the repository but it can not be reached:

	root@fileserver ~# ping il.archive.ubuntu.com 
PING foss.isoc.org.il ( 56(84) bytes of data.
--- foss.isoc.org.il ping statistics ---
876 packets transmitted, 0 received, 100% packet loss, time 881999ms.


I can ping archive.ubuntu.com just fine.

When using the webshell I can not run

	apt-get update

either, it is stuck on [waiting for headers].


Anything else I can try? Changing the repositories maybe? I am afraid I will use the wrong ones though.



Alon Swartz's picture

As Jeremy mentioned, you should update the nameserver in the configuration console, not manually in /etc/resolv.conf as any changes will be overwritten.


Anyway, I confirmed that il.archive.ubuntu.com does not reply to pings, so that isn't the problem. I also confirmed that I can use the archive and it is working as expected, so something is strange.

Try using the default ubuntu archive: archive.ubuntu.com, by updating /etc/apt/sources.list.d/sources.list and security.sources.list

I am starting to think it is some local networking problem outside the scope of turnkey linux issues.

I am not using my regualr network here, and looking a bit more into it I found that while my windows machines all connect to the internet just fine, none of my linux machine can access the web, though they can all ping servers.

All of the machines are using manual IP configuraitons, and similar ones, so I am still a bit puzzeled.

I will try it on another network later on and see what I get.

If you have any ideas about this behaviour I would appreciate the help, but it does not seem to be a  turnkey linux issue so I understand if we just close this thread for now.

Thanks for the help,


Jeremy Davis's picture

[edit] In light of Alon's comment above, this post is no longer relevant. I'll leave it here anyway.

Just pinged it and not getting any response!?! Perhaps it's a bit flakey? Although that would strike me as strange seeing as it's the official Israel country mirror! Despite this there are other mirrors. The official list of Ubuntu archive mirrors can be found here. Or just use  archive.ubuntu.com (although it may be a little slow - even though the mirror you are using is a sub-domain, it's actually on a local server, or at least should be). For your convienience, here is the only one listed for Israel.

Perhaps check connectivity first though by pinging it. Then alter your sources.list file(s). To be on the safe side create backups of them before you do anything:

cd /etc/apt/sources.list.d
cp sources.list sources.list.backup
cp security.list security.list.backup

then edit the files with nano (nano source.list) replacing the url, save (<Ctrl><x>) then try again.

Alon Swartz's picture

Even if you don't need them, maybe someone else who finds this thread will, so here they are:

iwlist <nic> scanning
iwconfig <nic> essid <essid>
iwconfig <nic> channel <channel>

no encryption

iwconfig <nic> key off

wep encryption

iwconfig <nic> key <encryption_key>

wpa encryption

wpa_cli terminate
wpa_supplicant -Dwext -i<nic> -C/var/run/wpa_supplicant

wpa_cli add_network   --> <netid>

wpa_cli set_network <netid> ssid '"<essid>"'
wpa_cli set_network <netid> key_mgmt WPA-<auth>       # Authentication Suites
wpa_cli set_network <netid> proto WPA                 # Use RSN for WPA2
wpa_cli set_network <netid> pairwise <pairwise>       # Pairwise Ciphers
wpa_cli set_network <netid> group <group>             # Group Cipher

wpa_passphrase <essid> <encryption_key>    --> psk=<psk>
wpa_cli set_network <netid> psk '<psk>'

wpa_cli enable_network <netid>

Add new comment