Tac Tacelosky's picture

Brand new to Turnkey, EC2 and Redmine, signed up for all of them to avoid using our sys admins to install redmine on our dedicated (non-cloud) server.  Love the idea of installing an appliance on the cloud, and Turnkey seems like a great solution.

BUT the first thing I see is that it's an older version of redmine.  Since I'm trying to avoid using our sysadmin resources to do this, can someone point me to specific instructions to do the upgrade (that is, "just do an apt-get update" isn't enough, someday I hope it will be).



Jeremy Davis's picture

Redmine is not installed via the package manager (the version in the Ubuntu package repos is even older - v0.9.x IIRC). And regardless, even if it was, that wouldn't have been any help to you anyway (Ubuntu security & some bug fixes are backported rather than the version being updated).

Luckily for you someone has already done what you're hoping for. It seems pretty step-by-step (although I can't vouch for it) and although convoluted, the instructions seem quite concise. Anyway have a look at this post. Probably best to post any questions specifically relating to the upgrade process in reply to that post.

Now that's all well and good but another potential issue I see is an appliance updated like this running on AWS. As you possibly already know, appliances running on EC2 are non-persistent (ie when you turn them off they're gone along with all your data and custom config). With a stock standard TKL appliance that's fine because you can use TKLBAM to backup your data and the Hub can even start a new instance with all your data pre-loaded. Obviously this is not quite so easy with an appliance upgraded like this. But luckily I don't think it will be too hard. Have a look at the TKLBAM docs and you'll need to customise your TKLBAM backups so that it backs up your updated install. So a little bit of a fiddle and some experimentation and you should be able to get it all working sweet.

Keep us posted on how you go with it all. And assuming you get it all sorted be great to hear about your working TKLBAM custom config.

Tac Tacelosky's picture

Thanks.  I found that post shortly after I posted my question, and went through the steps (using the proper versions to get to the 1.2 release). 

Unfortunately, I got stuck when I finally tried to run the site, with the error "undefined method `name' for "actionmailer":String", which appears to be a gem version incompatibility.  Being so unfamiliar with gem, ruby, etc., I wasn't sure of the best way to fix it, so I found another cloud service offer a redmine 1.2 appliance. Alas, the install of that one completed, but it's still not working.

So I'll keep plugging away.  This is my first venture into the cloud, it's kinda fun.


Danilo Pires's picture

I've made a tutorial with the 0.87 to 0.9x version upgrade and the steps are very similar. I tried to follow your installation step by step and I've got and error at the gem installation process.

So I wrote down what worked for me.

Did the whole process til the step 10.

I substitute the command for (Just for information I took those procedures from the Redmine.org HowTo 1.2 Stable install in a debian distro and mixed with your tutorial):

STEPS #10, 11 and 12 >> (FOR THOSE USING THE TURNKEY REDMINE V11 you do not need the SUDO command, since this is not even installed at that distro).

gem install rails -v=2.3.11 --no-ri --no-rdoc


gem install rake -v=2.3.11 --no-ri --no-rdoc


gem uninstall rake -v=0.9.2

gem install rake i18n -v=0.4.2 --no-ri --no-rdoc


After that done just proceed with the next steps as mentioned.

I hope I can help those that had the same problem.


ADAM - Once again thanks for the dedication for writing the tutorial. It's great to see how the collaboration can handle everything. I had a lot of feedback when I made the tuto for the 0.87 version and I hope you experience the same. Thanks once again.

C ya.

Jeremy Davis's picture

That would be the first place to start. If that doesn't get you going in the right direction, then next I would sugget that you consult the docs/forums/mailing-list/etc of the plugin you are using. Maybe this is a common error with a simple fix?

Jeremy Davis's picture

They should be in /var/log/apache2 (or something similar - I'm not at all sure I don't use this appliance myself).

Hopefully that will give you a clear error that you can google or ask about in whatever support forum/mailing list the plugin developer offers.

Jeremy Davis's picture

In other words set up a new appliance and migrate your data into it. You could try with TKLBAM but considering that you are going from a very old appliance, that may be more trouble than it's worth.

Perhaps it's worth contacting the Redmine community and see if they have any ideas?

Add new comment