Jeremy Davis's picture

I'm currently having some issues with TKLPatch extracting the ISO. I first experienced these issues with my old (v11.0) based TKLDevEnv so I decided to start again from scratch. I installed TKL Core v11.2 to a new KVM VM (under ProxmoxVE 1.9) and all went well. I installed TKLPatch and all still seemed well, but now when I try to patch an ISO I get errors like this:

tklpatch turnkey-lamp-11.2-lucid-x86.iso concrete5-0.2

# extracting root filesystem and isolinux from ISO
Parallel unsquashfs: Using 1 processor
31696 inodes (33406 blocks) to write

[===-                                                        ]  2213/33406   6%
zlib::uncompress failed, not enough room in output buffer
[===-                                                        ]  2215/33406   6%
Failed to write turnkey-lamp-11.2-lucid-x86.rootfs/lib/i586/, skipping
[=====\                                                      ]  2872/33406   8%
zlib::uncompress failed, unknown error -3

Failed to write turnkey-lamp-11.2-lucid-x86.rootfs/lib/modules/2.6.32-33-generic/kernel/drivers/infiniband/hw/amso1100/iw_c2.ko, skipping
[=====\                                                      ]  2873/33406   8%
zlib::uncompress failed, unknown error -3

Failed to write turnkey-lamp-11.2-lucid-x86.rootfs/lib/modules/2.6.32-33-generic/kernel/drivers/infiniband/hw/cxgb3/iw_cxgb3.ko, skipping
[==========================================================/ ] 33075/33406  99%/usr/bin/tklpatch-extract-iso: line 53:  2868 Bus error               unsquashfs -d $rootfs $name.mount/casper/*root.squashfs

I've never had issues like this before. I verified the Fileserver and Core ISOs weren't corrupted. I have tried patching other TKL ISOs and having the same issue. I tried checking the (virtual) disk but that didn't help. I --purge(d) TKLPatch (and dependencies) and reinstalled (after a reboot). I reinstalled the whole VM (from scratch). I've done a full apt-get upgrade. And nothing seems to make any difference...

The strange thing about it is that errors seem to occur in random places (they don't error in the same place) and occasionally the process actually finishes (although the 'zlib::uncompress failed, unknown error -3' erros still occur at random places) but the ISO is useless.

Any ideas??

Jeremy Davis's picture

Following some further consideration, a little more testing and successfully running and patching some ISOs in a VBox instance of Core (running on a desktop) I'm fairly certain that it's an issue with PVE itself (which in retrospect I probably should have suspected as soon as my new install didn't work properly - demonstrating the same issues as my original TKLPatcher appliance).

I am running a disk check on the server currently and am hoping that that will solve the issue (fingers crossed) but if not has anyone got any ideas??

[update] Repairing disk and LVM errors on the PVE host system (which required use of a live CD - repairs from single user environment were unsucessful) seem to have resolved this issue. It still seems strange that this was the only issue I noticed, but no issues since disk repairs so seems too coincidental for that not to have been the cause.

Add new comment