Peter Goodall's picture

I have downloaded several times from to make sure the file has not been corrupted on download.

The zip file checks ok for integrity with the Ubuntu archive manager.

When I try to import the Vm into VirtualBox 4.1.2 I get the following error:

Failed to import appliance <...>/turnkey-core11.2-lucid-x86.0vf

Could not create the clone medium '<...>/turnkey-core11.2-lucid-x86-disk1.vmdk'

Result Code: VBOX_E_FILE_ERROR (0x 80BB0004)

Component: Appliance

Interface IAppliance {<some sort of hash key>}

I am running Ubuntu Lucid as a workstation and have about 400GB free on the host volume.

Q: If the zip archive has no integrity problems, is there a possible problem with the original turnkey assembly that was zipped up?

P.S. I checked the file signature with gpg and and it was fine...


--Peter G

Eric (tssgery)'s picture

I've deployed this very ovf to VMware vSphere numerous times and have had no problems whatsoever. I suspect that either the unzipping or VirtualBox deployment is causing the issues. Have you tried deploying other turnkey ovf images, and did you experience similar problems?

Eric (tssgery)'s picture

I would suspect some kind of mismatch between the OVFs that are generated by TurnKey and what VirtualBox is expecting. I don't have a VirtualBox instance around to test with but maybe someone else does.

In the meantime, you can install these same applainces from the iso's if you'd like. During the creation of the VM just remember that Turnkey is based upon Ubuntu 10.04 32 bit.

Jeremy Davis's picture

Running Vbox 4.1.4 on WinXP this imports fine. It does throw an error at one point but it seems to be because the vmdk is not where it expects it to be and despite the error, continues merrily on it's way. I haven't tried on a Linux host for some time but last one I did (v11.0 on VBox 3.x? - Ubuntu 10.04 host IIRC) it worked fine.

As tssgery says above, worst case scenario you can install from ISO. I know it's not as quick as easy but you should have no issues there.

Add new comment