Guys please help, I installed an instance of Drupal 6 on TKLBAM EC2. I backed up the configuration using webmin so I can restore it later. When I restored the instance from TKLBAM EC2 the backup went to the famous Drupal Already installed page. I clicked Exising site and nothing happend.

Why didn't the restore just give me back the site I been working on. I would hate to do all of that work all over again. Any help is appreciated.


Jeremy Davis's picture

So not going to be much help. But just to clarify: Using TKLBAM you backed up your TKL Drupal6 and you then restored your backup to a fresh EC2 instance? If it's a Micro instance, maybe check that it's not recycling your old EBS volume (I'm not sure how Micro instances work so perhaps that's not a possibility?)

Assuming the backup all went ok, all your data and work should still be there, just for some reason it's not giving you access to it.

Hopefully someone with more knowledge than me will be along to be a bit more helpful. In the meantime perhaps posting on the Drupal forums might be worth a shot? Perhaps someone over there has some useful info for you?

And I know it's of no use to you right now and it's probably the last thing you want to hear, but it pays to check backups before you need to rely on them.

For some odd reason the backup restored the Drupal /usr/share/drupal6/tmp/install_redirect.php like it was a new install. I followed the steps on the Drupal appliance website (remove /usr/share/drupal6/tmp/install_redirect.php) and now it's working. Thanks Jeremy for the quick reply.

I guess I should have looked first. But I thought that a backup should work exactly as you left it. But we all know that 50% of the time restores don't always work as they should but thanks anyway.

Hopefully this post can help some one else.

Jeremy Davis's picture

But I'm glad you got it sorted!

And I'm sure that info will help someone else.

Hopefully the core devs can have a look at it to and adjust the TKLBAM Drupal6 template so that this doesn't happen again (or work out why it happened in your instance if it shouldn't have).

Tammie's picture

This has helped me...twice.

Ryan's picture

I am using TKL Drupal 11.3.  I was running into this also using local VM's on Virtualbox and using the TKLHub for migration.  Renaming the /usr/share/drupal6/tmp/install_redirect.php fixed my problem too.  

One other thing I noticed however that I wanted to share/ask about, is re: what is backed up with TKLBAM.  On my source VM, I ran a full backup into TKLHub (AWS S3).  On my destination VM, I ran a restore from the hub.  I left all the settings as default.

When I backed up, I noticed only the /usr/share/drupal6/files and another folder seemed to be included in the backup.  When I ran the restore (and after renaming install_redirect.php), the content was there but not my theme, layout, etc.   On my destination VM, I looked at /usr/share/drupal6 and noticed that really nothing was carried over.  

I modified the source VM's TKLBAM advanced settings to include /usr/share/drupal6, re-ran the backup, then re-ran the restore and everything was there.  During the backup, I noticed the themes, modules, files in durpal6 root, all were now included in the backup.

I don't know if this is the right or wrong fix, and unsure if anyone else has run into this.  I tested this a couple times and the results were always the same.  It's important to note that I was using 11.3 Drupal TKL appliances, deployed on Virtualbox using OVF.

Jeremy Davis's picture

And ideally shouldn't be touched by end users. It's a file location handled by package management and as such can have potential negatvie impacts when overwritten by TKLBAM... For more details/explanation see Liraz's post on Drupal 'naughty places' and another 'naughty places'/TKLBAM post.

Add new comment