Forum: 
Tags: 

Turnkey Trac is very slow

mark young's picture

I recently installed Turnkey Trac on a ESXI system running a few other (non-Turnkey) VMs.  While the other VMs perform reasonably, the Trac VM is very slow.  It takes 10 to 15 seconds to show a page after a click, which, according to my users, is un-usable.

I've gone so far as to completely delete the VM and re-download and re-deployt Turnkey Trac, with the same results.  There even appears to be a delay on the command line, after a command is run for a few seconds.

Any ideas?

 

 

    System load:  0.66              Memory usage:  53%
    Processes:    93                Swap usage:    0%
    Usage of /:   4.1% of 16.73GB   IP address for eth0:  ****
 
mark young's picture

Also, according to the js log, jquery.js is missing.

mark young's picture

I guess the reason I'm running slow is that I had to "disable acceleration" just to get it running at all, which I picked up here: http://www.turnkeylinux.org/forum/support/20110202/ovf-machine-not-running-esxi4

 

So, I can either run unusably slow, or not at all.  

Jeremy Davis's picture

Seems like there are quite a few. Either install a newer kernel (there is a backported one in lucid-update) or try adjusting the settings as described in that thread would be my 2 suggestions.

mark's picture

I have, but it hasn't made too much of a difference yet.
Jeremy Davis's picture

And then re-enable acceleration. Is that what you've done?

mark's picture

Yes. So, then I found http://www.turnkeylinux.org/forum/general/20101216/call-suggestions-bug-... and did that "backport-maverick" business and that didn't make much of a difference (though I really don't know what it was supposed to do!) Things like viewing active tickets takes 5 to 20 seconds per page display! System load is <0.50.
Jeremy Davis's picture

It is an updated kernel - to resolve the kernel panic issue, which from your posts it seems is why you are running with acceleration disabled!?

I assume that your server is running slow because you have acceleration disabled...

mark's picture

I've un-checked "Disable Acceleration", but that hasn't helped the sluggishness much, which is quite surprising. I'm going to, i guess, try messing with some of these MMU virtualization settings. Kind of frustrating.
Jeremy Davis's picture

I don't run ESXi and only played with it briefly years ago and decided in favour of ProxmoxVE. IMO PVE is a superior FOSS (free open source software) virtualisation solution - at least for my usage scenario. I won't harp on about how great it is, but bottom line is all my TKL appliances run sweet as and as such I can't help you at all with ESXi. Sorry. AFAIK though it can be done. There are many other TKL users using ESX/ESXi successfully (although not sure about that particular appliance - but it should be immaterial).

Hopefully one of them will be along to give you a hand. :)

mark's picture

In the end, i abandoned Turnkey altogether and installed it on one of the existing VMs on the same hardware.  Runs lightning quick.

 

So, I guess Turnkey isn't the answer, with ESXi.

Jeremy Davis's picture

But glad to hear you solved your problem.

Post new comment