opdahl's picture

Hello gentlemen!

We have an installation at work of vTiger 5.2.2 that we are running on a non-TKL platform because you guys didn't have it in TKL when we started to use it. The database has grown, as has the number of users, and we are seriously considering going to an on-demand platform rather than self-hosting it. vTiger also just released a new version (5.3RC) that will be frozen in 2-3 weeks. This is putting the impetus on us now to upgrade and decide on a long-term solution at the same time.

So, my questions:

  1. vTiger has an automated migration function in the new 5.3 version that will take one form 5.2 -> 5.3 without any difficulty (Supposedly -- Haven't tried it yet.  :-|  ).   If we move to TKL's vTiger appliance now, will you or we be able to use that migration tool to upgrade?
  2. Is TKL going to release a vTiger 5.3 appliance when it officially released?
  3. What would the timing be on that?

Other than that, I just wanted to take the time to thank you all for some really excellent products. I use a TKL Core at home for some file hosting and backup (CrashPlan) activity, and it works just flawlessly, even on a meager Atom chip. Well done!



Liraz Siri's picture

Yes, the next major version of TurnKey vTiger will most likely be based on vTiger 5.3. We've been working on a new batch, but I can't give you a timeline yet. We release when everything is working to our satisfaction.

You'll be able to use TKLBAM to migrate between versions and then run vTiger's migration tool to update the database schema (I'm assuming that's what it does).

PS: Thanks for the positive feedback!

Dave's picture

So I tried this - using 5.3 source and as well the 5.3 patch - and I cannot get access to install.php - I keep getting Forbidden - You do not have permission to access this file....etc


Is this related to being setup differently on the TurnKey appliance (11.2) - or can you help me understand why this is happening?  I have even go so far as to reclusively change the permissions to the entire vtigercrm directory (and all sub files and directories) to Octal 0777 (total read, write, execute permission to EVERYTHING!)

Jeremy Davis's picture

Although I guess for testing it's not that big a deal... Though if the files/folders are owned by the webserver user account (www-data - ie chown www-data) and permissions are 755 then that should be more than adequite.

Perhaps check the Apache error log and see what that's saying? I think it should be /var/log/apache2/error.log

Another possibility is that there is an errant .htaccess file that is causing your problems. I don't know much about them though...

Dave's picture

Thanks for giving me a response.  I did what you said and checked out the error log.

Here's the culprit line:

client denied by server configuration: /var/www/vtigercrm/install.php

So I did a google search on the 'client denied by server configuration:' part.

Apparently apache2 after a certain version adds to the config files (sites-available) language that blocks everything.

Here's how it read in the vtigercrm file in /etc/apache2/sites-enabled:

NameVirtualHost *:80
NameVirtualHost *:443

<VirtualHost *:80>
    UseCanonicalName Off
    ServerAdmin  webmaster@localhost
    DocumentRoot /var/www/vtigercrm/

<VirtualHost *:443>
    SSLEngine on
    SSLCertificateFile /etc/ssl/certs/cert.pem
    ServerAdmin  webmaster@localhost
    DocumentRoot /var/www/vtigercrm/

<Directory /var/www/vtigercrm/>
    Options +FollowSymLinks
    AllowOverride All
    order allow,deny
    allow from all
Above in <Directory.....
I changed 'AllowOverride None' and deleted both 'order allow,deny' and 'allow from all'
Then I did the same thing in the /etc/apache2/sites-available/vtigercrm file (because I don't exactly know what this is - but I was able to read that these are the areas where these restrictions take place.)
Worked like a charm - no problem accessing install.php and performing the entire upgrade from there!  WHOOO-HOOO!!
I'm now working flawlessly (so far) on vTiger verson 5.30 with all my old data and user custom fields and layouts, etc all carried over.  Took all but about 10 minutes once I figured out the apache2 security restrictions.
By the way - I changed the files back to the original way after migration/upgrade complete and sure enough install.php is no longer accessible.  So probably the best policy so all my files and security issues are more buttoned up.  One of the files (sites-enabled directory) was already changed back - so I don't know how/when that happened or if was even necessary to change it in the first place - like I said - I'm sorta pressing buttons over here - dangerous I know - but with the beautiful ability to create back ups in minutes of my TurnKey Linux vTiger VMWare Image - no problem!  I probably trashed like 5 machines before I got this one to work.  All by copying and pasting a folder!  SWEET!  (And thank you TKL!)
BY THE WAY - THAT ONE TIP FROM YOU HELPED ME TO CLOSE OUT THE ENTIRE DAY (yesterday) OF ABOUT 12 HOURS LOOKING HOW TO DO THIS!  School of hard knocks, baby!  Thanks for being a tutor!
Jeremy Davis's picture

And glad that I could be of assistance.

FYI all of the configured sites are in /etc/apache2/sites-available then the sites that are actually enabled have symlinks in /etc/apache2/sites-enabled (pointing to the actual files in /etc/apache2/sites-available). The desirable way to enable and disable sites is via the a2ensite and a2dissite commands, and the configuration should be done via the config files in /etc/apache2/sites-available.

I suspect that the reason why "One of the files (sites-enabled directory) was already changed back" was because for that one you had already edited the 'real' file (in /etc/apache2/sites-available) so when you opened the symlink it opened the 'real' file and it had already been done.

So to make sure all is as it should be, I'd check that the contents of sites-enabled to make sure anything in there is only a symlink. I'm not sure how the TKL vTiger appliance is configured, but I suspect that you will only want the vtigercrm file there.

Dave's picture

Thanks for the heads up.  So I checked the vtigercrm in sites-available as well as the vtigercrm in sites-enabled.  Each file (contents) reads exactly as the other (which is the original before I made any changes - as I mentioned I changed them back after upgrade.)  So each one under <Directory... has Options +FollowSymLinks - I believe this is that to which you refer, correct?

Hey - on another unrelated related note....

Swap memory SUCKS on this thing.  Just one user doing a bit of browsing, record changing, adding calendar items, completing, etc. and SWAP gets filled up such that things slow down IMMENSLY!

Is vTiger known to be a sloppy leaky memory program?  How does one get better performance from their machine due to memory issues?

Thanks again...

Jeremy Davis's picture

So I have no idea where your problems are coming from. First thing I'd do is make sure you have enough RAM. The vTiger docs recommend 2GB.

Beyond that I'd suggest that you have a read through the vTiger wiki and/or forums. If you don't find anything of any value (or even if you do) it may be worth also posting on their forum to ask what sort of performance enhancements others are using.

If you have any joy making yours work better, be great if you post back. If they are suitable for a generic vTiger appliance, they may even make it into the next release as TKL pre-configurations!

BenL's picture


In the notes for vtiger, it is mentioned that migration capability was turned off for security reasons. How can I turn it back on? Is there a flag in some file somewhere?

Add new comment