Edward Kam's picture
hi, there for some reasons, I keep getting error below when I try to restore a backup to a new vm instance. Tried restore a full and incremental copy but still the same. The only special part about this restore is I was trying to restore a backup from a S3 vm to a EBS vm (so I can use reverse instance). will this create problem? Thanks, -Edward ERROR 1153 (08S01) at line 911: Got a packet bigger than 'max_allowed_packet' bytes Traceback (most recent call last): File "/usr/bin/tklbam-restore", line 313, in main() File "/usr/bin/tklbam-restore", line 301, in main restore.database() File "/usr/lib/tklbam/restore.py", line 106, in database limits=self.limits.db, callback=mysql.cb_print()) File "/usr/lib/tklbam/mysql.py", line 402, in restore fs2mysql(mysql(), myfs, **kws) File "/usr/lib/tklbam/mysql.py", line 365, in fs2mysql MyFS_Reader(myfs, limits, skip_extended_insert, add_drop_database).tofile(fh, callback) File "/usr/lib/tklbam/mysql.py", line 359, in tofile database.tofile(fh, callback) File "/usr/lib/tklbam/mysql.py", line 252, in tofile table.tofile(fh) File "/usr/lib/tklbam/mysql.py", line 308, in tofile fh.write("(%s)" % row) IOError: [Errno 32] Broken pipe
Edward Kam's picture

just realized the error message is actually tell me exactly what's wrong.  Got a packet bigger than 'max_allowed_packet' bytes Traceback.  increasing the 'max_allowed_packet' variable in mysql to 100MB and the problem fixed.

L. Arnold's picture

My experience with Magento (not consistently yet) but it has worked is that it is best to first

increase your max_allowed packet


TKLBAM-restore XX --skip-database


TKLBAM-restore XX --skip-files --skip-packages


Change your IP to a Public IP


Restart  (not at the first prompting after first restore)


Failing this, where I am now, It is also worth Manually Backing Up Databases, then Manually Restoring them.  I understand PostGres Databases need to be treated this way right now as well.

Sometimes it is a specific Database or Set of Databases causing the problem (log files for instance) that you may need to exclude.  The error of broken Pipe will point to one Database but the last time I saw the error it was in fact the Database right before it that broke the Pipe.  These really were not huge data files either... but bigger than the rest to be sure.

Hitesh's picture

Hi Support,

I'm having issues on restore a full backup, I have successfully completed using webshell --database. Appliance version 11.2. This to create a testbed to a live version already in place.

Every time I use --skip-files --skip-packages I get the following error? I have increased max allowed limit?

Anything else I could try? would appreciate any advise?

Many Thanks,

Jeremy Davis's picture

Answered your other post...

Add new comment