28mikes's picture

My Win Vista Home premium will not connect to my File Server Appliance so I can view the folders and files. I am able to connect to the fileserver from Vista for the Webmin and Extplorer but I cannot access it from Run> \\ipaddress. I am getting server cannot be accessed.

I have looked at other forums that suggest changing the (LSA) Sercurity level from 3 to 1 in the registry and done that but still has solved my problem. ( HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\)

Is there any way I can get my Vista Home Premium to connect to the file server so I can upload files?

Also where do I create a folder so that it can be accessed and used for just storing what ever I would like to save there because creating one on the root does not seem to be working?

Jeremy Davis's picture

Assuming that you are, TBH I have no idea.

I have very little experience with Vista. I have successfully used Win7 with Samba 3 (as included in TKL Fileserver) but it was painfully slow (to connect and to navigate through the folders). It was a while ago, but I recall needing to do some reg edits (which I should have documented, but didn't). I spent a lot of time trying to tweak it to get it to work a bit better and managed to stop it working altogether... So ended up abandoning it. My purpose was for (read only) shared documents in a small business. In the end I went for KnowledgeTree accessed via WebDAV (which works well). I found even shares hosted on Win Server 2k3 are very slow when accessed from Win7.

At home I use Linux desktops & laptops so no issue there (I mount Fileserver shares using sshfs) but my son has a Win 7 desktop. I don't know what he did, but his machine can access the shares no worries but it is still quite slow.

But I guess none of that helps you any, other than to suggest that it should be possible (I would think surely if Win7 can connect then Vista should be able to too!?).

I will ask my son if he recalls what he did.

28mikes's picture

I have done one of the regedits I have seen popping up on most forums but that has not helped like this one here .

What I need is a FileServer that is going to be running on my ESXI host and I need to use it to place my files there so they can be accessed by all my Virtual Machines. At the moment I have to copy data onto cd and then run it off the host like when I need to install Antivirus, Service Packs and Winzip.

I might have to look for another Linux File Share Virtual Appliance.

Jeremy Davis's picture

But what about using the VMware shared folders? I haven't used ESXi much (I had a play initially but then dumped it when I found Proxmox). But I guess that it can use the VMware shared folders? The VM images have the VMtools preinstalled by my understanding. Perhaps that will serve your purposes easier and more reliably?

Rolando Pintro's picture

In theory, it would be nice to deploy a linux file server using Samba and make the shares available to any Windows system or other platforms without having to worry about the connection licensing compliance requirements that one would have to consider if they hosted a Windows server.  However, it became clear that the performance issues such as the slowness that you mentioned on this post as well as Chris's comment on my recent post.  Samba or in this case TKL File Server appliance is not the solution.  It would be worth the while if someone could chime in with their own success story.

Does anybody out there have Windows systems persistently mapping to linux Samba shares either on local networks or through VPN connections over the web without the extremely slow performance that we are reading about?  If not with Samba, what service did you use and what is your recipe?

Rolando Pintro's picture

I did some further research and learned that the slownes might be more of a Windows problem than Samba.  Perhaps the link below might help with the slowness.  Sorry, I don' have a fix for the connection issue.  I still have not overcome it myself and I am no longer considering using samba shares for my project.

Windows 7 Network Slow – 6 Easy Ways to Make it Fast


Jeremy Davis's picture

I don't recall whether that was the exact thing I followed, but it was definately something similar. After my initial issues with Samba I tried with a Win 2003 server share - and same issues.

After a lot of tweaking (and as I think I said somewhere else, at one point completely destroying network connectivity from the Win7 machine altogether) I got it sort of working ok, but was still noticably slower than from XP - especially initial connection. Connecting on boot (as discussed below) may help there (if it is doing the connection as it starts that may mean the end user doesn't notice the intial slowness). As this was a laptop that wasn't going to work, so I gave up and just synced the data I wanted access to. Messy solution really, but a solution never-the-less.

As I said elsewhere my son has it pretty working ok on his Win7 desktop but it is still noticably slower to connect (than XP) and on occasion seems to just lock up. Large data transfers are still quite slow. In my online travels I have seen benchmarks on file transfer comparison between WinXP/Server2k3/Samba3 and Win Vista/7 and they seem comparable (suggesting that the issue is with Win Vista/7 and its backwards compatability with old Win sharing, rather than a Samba3 specific issue). I haven't tested Samba4 but perhaps that doesn't have the same issues?

Also I asked my son about his Win7 desktop and he said that he couldn't remember, but didn't thik that he did any tweaks!?

Liam Pool's picture

I've got a Debian sever running samba as the main file store for our house hold media. I built this about 4 years ago, so I"m a bit rusty on how I tuned it, but in general after the initial 'file scan' that windows does to look at and get a listing of all the files in the directory, it seems no different to connecting to a windows share. 

I have my win 7 machine auto connecting to this on start up (i remember that was a pain to get working)

I also run a PVR that connects to this share as well. 



Jeremy Davis's picture

Even when connecting to Win 2k3 server shares (as I just said above) Win7 displays the same sluggishness for me (and I have tested a number of configurations - with a number of different machines, on 2 different networks - the sluggishness has been consistent).

Do you think that connecting on boot helps reduce the obviousness of being slow to connect (as I suggested above) or is it actually working for you comparable to XP?

Do you recall what (if any) tweaks you did to your Win7 machine? Also are you using Samba3 or 4 on your Debian server? What version of Win7 are you using?

I have a suspicion (backed by someone else's annecdotal evidence) that perhaps its not as bad when using Win7 business/enterprise focused editions (as compared to home versions) as perhaps MS anticipated that business users may be connecting to older Win servers; whereas it was likely to be less an issue with home users... Although now I put that in black and white it sounds a little like a conspiracy theory!! :)

Liam Pool's picture

Not sure on the samba version debian is running. All my versions of windows have always been the 'pro version (Xp Pro, Vista business, win 7 pro) as when I was working in a local PC shop some year ago, the training given to me was said the home one always has crippled netowrking capabilities, Not 100% if thats followed through to vista/7, but I won't be surprised if it has. 

I'm noticing no difference between my wife's XP pro machine, and my win 7 pro machine. 

I just have it set to connect on start up for convienience (as some of the applications I  run use that share to store data, so it's easier having it connected than having to remember to connect. 



Jeremy Davis's picture

I suspect that if you're not sure what version of Samba then it would be 3 rather than 4.

Yes I think you are right, 'crippled networking' sounds likely... And perhaps that is where these issue come into play.

28mikes's picture

@JedMeister I have just downloaded the Linux File Server Appliance from turnkeylinux so I am not sure of what version I am using.

Can you let me know how I can check what version I am using and if I am able to upgrade it?

I am starting to think it might be a firewall setting on my Esxi vswitch because Windows 2008 server Vmachine connected fine but I am yet to try Win 7 Businesss running on a laptop.

Jeremy Davis's picture

Even in the upcoming Ubuntu 12.04, Samba3 is still the default package. Samba4 is in the Ubuntu 10.04 repos (included in TKL v11.x already) though. I have limited (read: no) experience with it and I'm not sure if the Webmin module would work with it. There was another TKL user some time ago that was using it but I don't recall the details.

I'm not sure whether it would install alongside, or if you'd need to install it separately. The version of Samba4 in the repos is named as an 'alpha' version, which generally is a bad thing, but I have read numerous reports that it is pretty much stable and close to a final release (although that has been said for a long time now and I note that the version in Ubuntu 12.04 is still 'alpha').

The package is called 'samba4" so:

apt-get install samba4

but as I say above, I don't know what implications that would have on your existing setup. It may trash your current Samba config and leave you to config manually (if Webmin module doesn't work with it).

Personally I would continue to explore other options and leave that as a last resort.

28mikes's picture

I still need help with the tweaks that other have done to enable vista to see the shares. Windows 2008 Server can connect without any tweaking and I am thinking that they Vista and Server 2008 are similar so I guess my problem might be to do with a firewall setting on my ESXI host where the Samba file server is hosted.

Jeremy Davis's picture

I don't recall having to do any tweaks to get it to connect (although I was using Win7 - not Vista). I just tweaked it to try to get it to work better. As I already posted (somewhere here) my son didn't think he did anything to his Win7 PC to get it to work as it does. Perhaps there is some server side Samba tweak required (but I don't recall doing that either - but I set mine up a long time ago).

28mikes's picture

I have isolated the problem to just Windows Vista Home Premium because other OS which are not hosted on ESXI can connect so the problem is not down to vswitch on ESXI. Windows 7 Pro did not even need any tweaking.

I am 100% sure there is a setting on Vista I need to change to allow Samba compatibility.

Jeremy Davis's picture

And it seems that there are 2 reg edits people are suggesting, a Samba config edit and some other stuff floating about... I can't confirm any of this info, it's just what turned up from google and it is completely unqualified and untested! I'm not sure which (if any) will work for you, or perhaps you need some combo?:

Vista reg edit 1:

Set HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa\LMCompatibilityLevel from 0x3 to 0x1 to switch from "0x3: Try NTLMv2" (Confuses samba) to "0x1: Negotiate NTLMv2 if possible, Try NTLMv1, else use MSLANMAN".

I also read that "0" works even 'better', although obviously this would only be safe if you trust your internal network users and systems.

Apparently this can/should be done via security policy but many people say that it's not available in Vista (some say not available in home OS, others say not in Vista at all) so not clear on that, but here is instructions I found anyway:

Run secpol.msc
Go to: Local Policies > Security Options

Find "Network Security: LAN Manager authentication level"

Change Setting from "Send NTLMv2 response only"
"Send LM & NTLM - use NTLMv2 session security if negotiated"

Vista reg edit 2:

Set the key

and, again, the name of the parameter is:  EnablePlainTextPassword

to 1."

Samba config edit (this seems pretty old info so not 100% sure it is valid):

In smb.conf

valid users = %S
users = %S

Other Vista notes:

Apparently Vista requires a domain identifier before the username. So for users without a domain controller, use the workgroup name (often default is WORKGROUP) instead of a domain identifier. Eg "WORKGROUP\username"

Edit "Network security: Do not store LAN Manager hash value on next password change"
setting from "enabled"
(I have no idea where this may be - just cut and pasted it from a random forum post - apparently this matches the default setting i
n XP!?)

Guaranteed workaround:

Ditch Windows and install Linux! :D

Then you don't even have to muck around with Samba anymore, you can directly mount the remote filesystem using SSHFS!


Chris Musty's picture

The registry hacks do nothing to speed things up - I have spent hours and hours trying.

It is well documented that vista sucks with networking and I would concur.

For best results make samba as open as possible, if you trust the network.

If you dont, then dont use vista.

If you must use vista you will need samba 4.

To get you running below is a a typical config file I use for minimal resistance but note it is in no way secure... Start with it and work backwards to get the right security settings working.


BTW I agree with the guaranteed work around!


netbios name = FileServer // Whatever you use
netbios aliases = FileServer // Whatever you use
server string = FileServer // Whatever you use
delete readonly = yes
read only = no
writable = yes
workgroup = WORKGROUP // Whatever you use
guest ok = Yes
public = yes
security = share
max log size = 1000
wins support = true
path = /srv/CDrive // Whatever you use
path = /srv/DDrive // Whatever you use

Chris Musty


Specialised Technologies

Add new comment