USB external hard disk not detected to make local backup Turnkey PDC appliance

Santiago Gonzalez's picture

Hi everyone

I deployed Turnkey PDC in a ESXi v5.0 free server. The Turnkey Virtual Appliance is working great and I configured TKLBAM to make backups in Amazon S3, but we also need to make a local backup in a external USB hard disk.

When I plug the external USB hard disk (FAT32 formatted) the Turnkey doesn't recognize it. Restarting the virtual machine with the hard disk plugged has the same result, when I check with a fdisk -l only the virtual hard disk from the ESXi server appears.

On the ESXi server we've got another virtual machine that runs Windows 7, and when we turn on it, Windows detects the external USB hard disk without troubles. So the problem with the Turnkey PDC Virtual Appliance is not on the ESXi server configuration, something has to be missing (configuration or a Ubuntu package) in the Turnkey to not recognize the hard disk.

I tried installing usbutils packages, but didn't help to this problem.

Any ideas?

Thanks in advance

Jeremy Davis's picture

IIRC having VM tools is required for USB passthrough. AFAIK VMware VM tools are preinstalled for the TKL VM image (zip file) but not the ISO. If you installed from ISO that would explain it (assuming I'm right). Perhaps just to test, try using the VM image (if you're not already). Installing VM tools can be painful from what I've read...

Also I have no idea about ESXi and how it works (never used it other than brief testing a long time ago) but surely an easy workaround would be to just mount the USB on the host system and connect to it from your guest using some network protocol such as Rsync/SFTP/NFS/CIFS/etc?

Santiago Gonzalez's picture

Thanks for your answer Jeremy.

I have VM tools installed (version supplied by the ESXi 5.0 server). The Virtual Appliance that I deploy on the ESXi server was the OVF file.

I would try the workaround you suggested.

Thanks

Jeremy Davis's picture

So you're using the OVF which should come with VM tools preinstalled. I wonder if it's got 2 versions installed side by side if you have also installed it? I am completely stabbing in the dark here...

Post new comment