Hi,

I m planning to use Redmine(1.3.5) under Reverse Proxy server (nginx).

For that I have to change to the url of Redmine applicance from http://hostname/ (current redmine url) to http://hostname/redmine

 

using ref: http://www.redmine.org/projects/redmine/wiki/HowTo_Install_Redmine_in_a_...

I tried putting

Redmine::Utils::relative_url_root = "/redmine"

to /var/www/railsapp/config/environment.rb

Pages do work but all images / js / css are broken.

Forum: 
Jeremy Davis's picture

But a quick glance at the TKL Remine appliance manifest shows that Apache is installed on this appliance by default, so I would suspect that perhaps you need to adjust the default virtualhost as well...?

Dan Hoang's picture

I know this thread is old but using https://wiki.debian.org/redmine help me.

editing /etc/apache/conf/sites-available/redmine.conf:

	ServerAdmin  redmine@mind.uci.edu
	RewriteEngine On

	# Rewrite index to check for static
	RewriteRule ^/$ /index.html [QSA]

	# Rewrite to check for Rails cached page
	RewriteRule ^([^.]+)$ $1.html [QSA]

	#DocumentRoot /var/www/redmine/public/
	Alias /redmine /var/www/redmine/public/

	<Location /redmine>
	     PassengerBaseURI /redmine
	     PassengerAppRoot /var/www/redmine/
	</Location>

	<Directory /var/www/redmine/public/>
	    Options +FollowSymLinks
	    AllowOverride all
	    Order allow,deny
	    Allow from all
	    RailsBaseURI /redmine
	    RailsEnv production
	</Directory>
Jeremy Davis's picture

Thanks so much for sharing your experience and information.

I hope you don't mind but I reformatted your post.

Add new comment